Bug 832861 - User account register and login problem in community page.
User account register and login problem in community page.
Status: CLOSED NOTABUG
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-18 00:34 EDT by mcao
Modified: 2015-05-14 21:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-18 09:23:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the display of /community/user on devenv_1850 (206.68 KB, image/png)
2012-06-18 00:34 EDT, mcao
no flags Details

  None (edit)
Description mcao 2012-06-18 00:34:08 EDT
Created attachment 592505 [details]
the display of /community/user on devenv_1850

Description of problem:
When I click "sign in to participate" in community page, It will redirect to the page /community/user, and In this page, I cannot login correctly with valid username and password. There are some display mistake of the page as well.
In addition, the /community/user/register page and /community/user/password page cannot work well. When I register a user in register page or reset password in the password page , I cannot receive an email to confirm.

Version-Release number of selected component (if applicable):
devenv_1850
How reproducible:
always

Steps to Reproduce:
1.go to community page
2.click "sign in to participate"
3.input a valid username and password.
4.click "create  new account" ,and try to register a new account.
5.click "request new password"  , and try to reset a password.
Actual results:
These three page cannot work well.

Expected results:
When login with value username and password , users can be logged in correctly.
When register a new account or reset password ,users should receive an email to confirm.

Additional info:
The "sign in " link in community of product is /app/login, not /community/users.But when user input URL as "/community/user",the same issue as devenv_1850 exists.
Comment 1 Clayton Coleman 2012-06-18 09:23:07 EDT
This the standard devenv configuration.  If you want single sign on like stage you must follow the instructions to enable it.

https://engineering.redhat.com/trac/Libra/wiki/Environments#Drupalinthedevelopmentinstance

Note You need to log in before you can comment on or make changes to this bug.