Bug 832949 - Gluster - Backend: Bad CanDoAction error on moving host with volumes to another cluster
Gluster - Backend: Bad CanDoAction error on moving host with volumes to anoth...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Vinayaga Raman
Prasanth
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-18 05:15 EDT by Daniel Paikov
Modified: 2014-03-30 21:29 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:25:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Paikov 2012-06-18 05:15:20 EDT
* Host with volumes/bricks on it.
* Move host to Maintenance.
* Try to move host to a different cluster.
* Cluster change fails with the following error:
"Cannot ${action} ${type}. Server having Gluster volume."


In engine.log, the failure looks like this:
2012-06-18 12:15:06,767 WARN  [org.ovirt.engine.core.bll.ChangeVDSClusterCommand] (ajp--0.0.0.0-8009-1) [262a09f6] CanDoAction of action ChangeVDSCluster failed. Reasons:VDS_CANNOT_REMOVE_HOST_HAVING_GLUSTER_VOLUME
Comment 2 Selvasundaram 2012-06-22 07:26:12 EDT
Fix submitted 
 http://gerrit.ovirt.org/5609
Comment 3 Selvasundaram 2012-08-09 02:20:38 EDT
Fix gone in with patch http://gerrit.ovirt.org/5972
Comment 4 Prasanth 2013-01-08 01:38:50 EST
Verified in Red Hat Storage Console Version: 2.1-qa18.el6ev

In engine.log, the failure now looks like this:

------
2013-01-08 03:57:55,701 WARN  [org.ovirt.engine.core.bll.ChangeVDSClusterCommand] (ajp-/127.0.0.1:8702-11) [4459193c] CanDoAction of action ChangeVDSCluster failed. Reasons:VAR__ACTION__UPDATE,VAR__TYPE__HOST,VDS_CANNOT_REMOVE_HOST_HAVING_GLUSTER_VOLUME
------
Comment 14 Scott Haines 2013-09-23 18:25:18 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.