This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 832975 - S390 kickstarts should have reboot command (RHEL7)
S390 kickstarts should have reboot command (RHEL7)
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: beah (Show other bugs)
0.5
Unspecified Unspecified
urgent Severity urgent (vote)
: 0.9.0
: ---
Assigned To: Bill Peck
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-18 06:02 EDT by Karel Srot
Modified: 2012-06-26 02:41 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-26 02:41:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Srot 2012-06-18 06:02:14 EDT
Description of problem:

Our test  are failing because some functionality (e.g. rlFetchSrcForInstalled) is not available on s390x RHEL7 systems (I saw it also on ppc64 system)

This is a log from fresh RHEL-7.0-20120614.n.1-Server-s390x installation (focus on file sizes):


[root@ibm-z10-29 beakerlib]# ls -l `rpm -ql beakerlib-redhat`
lrwxrwxrwx. 1 root root   33 Jun 18 05:41 /usr/lib/beakerlib/beakerlib.sh -> /usr/share/beakerlib/beakerlib.sh
-rw-r--r--. 1 root root    0 Mar  2 10:06 /usr/share/beakerlib/plugins/rh-internalAnalyze.sh
-rw-r--r--. 1 root root    0 Mar  2 10:06 /usr/share/beakerlib/plugins/rh-internalLogging.sh
-rw-r--r--. 1 root root    0 Mar  2 10:06 /usr/share/beakerlib/plugins/rh-internal.sh
lrwxrwxrwx. 1 root root   33 Jun 18 05:41 /usr/share/rhts-library/rhtslib.sh -> /usr/share/beakerlib/beakerlib.sh

/usr/lib/beakerlib:
total 0
lrwxrwxrwx. 1 root root 33 Jun 18 05:41 beakerlib.sh -> /usr/share/beakerlib/beakerlib.sh

/usr/share/beakerlib/plugins:
total 0
-rw-r--r--. 1 root root 0 Mar  2 10:06 rh-internalAnalyze.sh
-rw-r--r--. 1 root root 0 Mar  2 10:06 rh-internalLogging.sh
-rw-r--r--. 1 root root 0 Mar  2 10:06 rh-internal.sh

/usr/share/rhts-library:
total 0
lrwxrwxrwx. 1 root root 33 Jun 18 05:41 rhtslib.sh -> /usr/share/beakerlib/beakerlib.sh



Compare to x86_64 machine:

[root@x86-64-v01 ~]# ls -l `rpm -ql beakerlib-redhat`
lrwxrwxrwx. 1 root root    33 Jun  6 13:26 /usr/lib/beakerlib/beakerlib.sh -> /usr/share/beakerlib/beakerlib.sh
-rw-r--r--. 1 root root   388 Apr  5 10:28 /usr/share/beakerlib/plugins/rh-internalAnalyze.sh
-rw-r--r--. 1 root root   233 Apr  5 10:28 /usr/share/beakerlib/plugins/rh-internalLogging.sh
-rw-r--r--. 1 root root 14676 Apr  5 10:28 /usr/share/beakerlib/plugins/rh-internal.sh
lrwxrwxrwx. 1 root root    33 Jun  6 13:26 /usr/share/rhts-library/rhtslib.sh -> /usr/share/beakerlib/beakerlib.sh

/usr/lib/beakerlib:
total 0
lrwxrwxrwx. 1 root root 33 Jun  6 13:26 beakerlib.sh -> /usr/share/beakerlib/beakerlib.sh

/usr/share/beakerlib/plugins:
total 24
-rw-r--r--. 1 root root   388 Apr  5 10:28 rh-internalAnalyze.sh
-rw-r--r--. 1 root root   233 Apr  5 10:28 rh-internalLogging.sh
-rw-r--r--. 1 root root 14676 Apr  5 10:28 rh-internal.sh

/usr/share/rhts-library:
total 0
lrwxrwxrwx. 1 root root 33 Jun  6 13:26 rhtslib.sh -> /usr/share/beakerlib/beakerlib.sh
Comment 1 Karel Srot 2012-06-18 06:12:28 EDT
The system has been provided with:

# rpm -qa | grep beaker
beakerlib-redhat-1-6.el7.noarch
beaker-distribution-install-1.10-14.noarch
beakerlib-1.4-2.el7.noarch
beaker-distribution-reservesys-2.0-48.noarch


I was able to download and reinstall the package manually, seems to fix the problem:

[root@ibm-z10-29 ~]# wget 'http://beaker.engineering.redhat.com/harness/RedHatEnterpriseLinux7/beakerlib-redhat-1-6.el7.noarch.rpm'
--2012-06-18 10:11:22--  http://beaker.engineering.redhat.com/harness/RedHatEnterpriseLinux7/beakerlib-redhat-1-6.el7.noarch.rpm
Resolving beaker.engineering.redhat.com... 10.16.101.67
Connecting to beaker.engineering.redhat.com|10.16.101.67|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 7661 (7.5K) [application/x-rpm]
Saving to: `beakerlib-redhat-1-6.el7.noarch.rpm'

100%[====================================================================>] 7,661       --.-K/s   in 0s      

2012-06-18 10:11:23 (56.1 MB/s) - `beakerlib-redhat-1-6.el7.noarch.rpm' saved [7661/7661]

[root@ibm-z10-29 ~]# rpm -i --force beakerlib-redhat-1-6.el7.noarch.rpm 
[root@ibm-z10-29 ~]# ls -l `rpm -ql beakerlib-redhat`
lrwxrwxrwx. 1 root root    33 Jun 18 10:13 /usr/lib/beakerlib/beakerlib.sh -> /usr/share/beakerlib/beakerlib.sh
-rw-r--r--. 1 root root   388 Mar  2 10:06 /usr/share/beakerlib/plugins/rh-internalAnalyze.sh
-rw-r--r--. 1 root root   233 Mar  2 10:06 /usr/share/beakerlib/plugins/rh-internalLogging.sh
-rw-r--r--. 1 root root 14676 Mar  2 10:06 /usr/share/beakerlib/plugins/rh-internal.sh
lrwxrwxrwx. 1 root root    33 Jun 18 10:13 /usr/share/rhts-library/rhtslib.sh -> /usr/share/beakerlib/beakerlib.sh

/usr/lib/beakerlib:
total 0
lrwxrwxrwx. 1 root root 33 Jun 18 10:13 beakerlib.sh -> /usr/share/beakerlib/beakerlib.sh

/usr/share/beakerlib/plugins:
total 24
-rw-r--r--. 1 root root   388 Mar  2 10:06 rh-internalAnalyze.sh
-rw-r--r--. 1 root root   233 Mar  2 10:06 rh-internalLogging.sh
-rw-r--r--. 1 root root 14676 Mar  2 10:06 rh-internal.sh

/usr/share/rhts-library:
total 0
lrwxrwxrwx. 1 root root 33 Jun 18 10:13 rhtslib.sh -> /usr/share/beakerlib/beakerlib.sh
[root@ibm-z10-29 ~]#
Comment 2 Bill Peck 2012-06-18 16:25:46 EDT
This must be due to us rebooting the system with a power command instead of relying on anaconda to reboot the system.  We had to do this for Alpha1 but I think this can be turned off now.

We can use this bug to verify that.
Comment 3 Ondrej Hudlicky 2012-06-19 15:45:21 EDT
Thanks for accelerated fix!

Karel - target release for this fix June 25th, in the meantime try to workaround using funny test as first task and force there reinstall of the beakerlib packages. 
/CoreOS/examples/rhts_tutorial/psklenar/funny-test
Comment 4 Bill Peck 2012-06-19 17:18:50 EDT
http://gerrit.beaker-project.org/#/c/1149/
Comment 5 Dan Callaghan 2012-06-21 18:29:01 EDT
This bug has been addressed in Beaker 0.9.0-3 which is currently running on stage:

https://beaker-stage.engineering.redhat.com/
Comment 6 Dan Callaghan 2012-06-26 02:41:02 EDT
Beaker 0.9.0 has been released.

Note You need to log in before you can comment on or make changes to this bug.