Bug 832977 - [Storage] allow bootable shared disk (remove validation)
[Storage] allow bootable shared disk (remove validation)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.1.0
Assigned To: Gilad Chaplik
Leonid Natapov
storage
: Reopened
: 833336 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-18 06:05 EDT by Leonid Natapov
Modified: 2016-02-10 11:27 EST (History)
11 users (show)

See Also:
Fixed In Version: SI13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 14:58:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leonid Natapov 2012-06-18 06:05:03 EDT
[Storage] when adding or attaching disk ,please greyed out (disable) "bootable" option   if "shared" is selected and vise versa. Disk can't be bootable and shared  at the same time. Now,you can select both bootable and shared. Although there is a warning message appear saying that disk can not be bootable and shared at the same time I don't see any point to allow to user to select those two options together if they can't work together.
Comment 1 Ayal Baron 2012-07-05 14:41:38 EDT
There is absolutely no reason to prevent a shared disk from being bootable.
Comment 2 Gilad Chaplik 2012-07-05 17:03:21 EDT
(In reply to comment #1)
> There is absolutely no reason to prevent a shared disk from being bootable.

reopened the bug; changed the subject & component (the validation is in the backend - canDoAction)
Comment 5 Leonid Natapov 2012-07-29 11:26:21 EDT
si12. shared disk can be bootable.
Comment 7 Ayal Baron 2012-08-26 06:12:14 EDT
*** Bug 833336 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.