Bug 833001 - shotwell does not start, needs old version of libgexiv2
shotwell does not start, needs old version of libgexiv2
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: shotwell (Show other bugs)
17
i386 Linux
unspecified Severity high
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-18 07:25 EDT by Martin Ellison
Modified: 2012-06-30 22:39 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-30 22:39:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Ellison 2012-06-18 07:25:20 EDT
Description of problem: shotwell needs old version of libgexiv2


Version-Release number of selected component (if applicable): shotwell 0.12.3


How reproducible: always on my box


Steps to Reproduce:
1. try to run shotwell
  
Actual results: shotwell: error while loading shared libraries: libgexiv2.so.0: cannot open shared object file: No such file or directory


Expected results: shotwell should run and open normally


Additional info: current version is /usr/lib/libgexiv2.so.1.0.0
Comment 1 Thomas Moschny 2012-06-25 15:15:57 EDT
Cannot reproduce this on my x86_64 F17 maschine.

% rpm -qf /usr/bin/shotwell
shotwell-0.12.3-1.fc17.x86_64

% ldd /usr/bin/shotwell | grep gexiv
	libgexiv2.so.1 => /lib64/libgexiv2.so.1 (0x000000313de00000)

% rpm -qf /lib64/libgexiv2.so.1
libgexiv2-0.4.1-1.fc17.x86_64

Can you please double-check?
Comment 2 Martin Ellison 2012-06-30 22:36:47 EDT
The problem is that shotwell wants version 0 of the library, but it is getting version 1. (I am on 32 bits by the way). I would have thought that the solution was to rebuild the same sources against the current libraries and push a new rpm version. (I have unrelated problems building the latest sources so I cannot go that way).

> shotwell
shotwell: error while loading shared libraries: libgexiv2.so.0: cannot open shared object file: No such file or directory
> ls -l /usr/lib/libgexiv2*
lrwxrwxrwx. 1 root root     18 Jun  4 14:33 /usr/lib/libgexiv2.so -> libgexiv2.so.1.0.0
lrwxrwxrwx. 1 root root     18 Jun  4 12:42 /usr/lib/libgexiv2.so.1 -> libgexiv2.so.1.0.0
-rwxr-xr-x. 1 root root 123876 Apr  3 20:59 /usr/lib/libgexiv2.so.1.0.0
> sudo yum list '*gexiv*'
Loaded plugins: langpacks, presto, protectbase, refresh-packagekit
http://linux.dropbox.com/fedora/17/repodata/repomd.xml: [Errno 14] curl#56 - "Network error recv()"
Trying other mirror.
0 packages excluded due to repository protections
Installed Packages
libgexiv2.i686                                                                         0.4.1-1.fc17                                                                   @anaconda-0
libgexiv2-devel.i686                                                                   0.4.1-1.fc17                                                                   @anaconda-0
> sudo yum upgrade -y libgexiv2
Loaded plugins: langpacks, presto, protectbase, refresh-packagekit
http://linux.dropbox.com/fedora/17/repodata/repomd.xml: [Errno 14] curl#56 - "Network error recv()"
Trying other mirror.
0 packages excluded due to repository protections
No Packages marked for Update
> uname -a
Linux edward 3.4.3-1.fc17.i686.PAE #1 SMP Mon Jun 18 20:31:39 UTC 2012 i686 i686 i386 GNU/Linux
Comment 3 Martin Ellison 2012-06-30 22:39:59 EDT
Sorry, found the problem, I was running an old build; if I run /usr/bin/shotwell I'm fine. I've closed the ticket.

Note You need to log in before you can comment on or make changes to this bug.