Bug 83304 - installer hang during package installation.
Summary: installer hang during package installation.
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda
Version: phoebe
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-02 01:14 UTC by Michael Fratoni
Modified: 2007-04-18 16:50 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2003-02-11 17:38:26 UTC


Attachments (Terms of Use)
/tmp/anaconda.log (3.38 KB, text/plain)
2003-02-02 01:17 UTC, Michael Fratoni
no flags Details
/mnt/sysimage/root/install.log (1.97 KB, text/plain)
2003-02-02 01:18 UTC, Michael Fratoni
no flags Details
/tmp/syslog (19.82 KB, text/plain)
2003-02-02 01:18 UTC, Michael Fratoni
no flags Details

Description Michael Fratoni 2003-02-02 01:14:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
While doing a clean install of Pheobe2, the installer hung at 12%
complete, after installing the aspell package. 'top' reported 99.6 percent CPU
usage by anaconda. It remained this way for over an hour.
The machine was not hung, as the shell on VT2 remained usable.

Version-Release number of selected component (if applicable):


How reproducible:
Couldn't Reproduce

Steps to Reproduce:
1. Currently attempting re-installation.
2.
3.
    

Additional info:

Attaching copies of the anaconda logs as requested by Matt Wilson.

Comment 1 Michael Fratoni 2003-02-02 01:17:05 UTC
Created attachment 89772 [details]
/tmp/anaconda.log

Comment 2 Michael Fratoni 2003-02-02 01:18:03 UTC
Created attachment 89773 [details]
/mnt/sysimage/root/install.log

Comment 3 Michael Fratoni 2003-02-02 01:18:51 UTC
Created attachment 89774 [details]
/tmp/syslog

Comment 4 Michael Fratoni 2003-02-02 05:00:04 UTC
The second install completed with no problems.



Comment 5 Michael Fulbright 2003-02-03 18:55:49 UTC
Was this a CD based installation?

Comment 6 Michael Fratoni 2003-02-04 00:04:33 UTC
Yes, this was a CD based install.
I din't use the installer to verify the media on the install that failed.
I did however verify the md5sums of both the iso images and the CD media.

As a test, I started the installer again, and the media passed the media check.

Comment 7 Michael Fulbright 2003-02-04 20:15:10 UTC
When you dd'd the CD to manually verify its md5sum did you notice a long delay
at any point? I'm guessing the delay was the CD drive retrying over and over to
read a marginal section of the image.


Comment 8 Michael Fratoni 2003-02-05 02:45:09 UTC
I didn't see any delay in checking the disks.

I also didn't notice any disk or cdrom activity when the install stopped. 
If the problem were related to a problem reading the CD, I'd have expected
to hear the CDROM spinning as it tried to read.

To me, and this is pure speculation, it appeared that rpm had hung.
Aspell had installed, the progress bar (for the package) went to 100 percent.
That is where it stopped, as if the aspell rpm transaction had hung.

It never indicated it was attempting to install the next package.

I can try a few more installs letting the installer verify the media if you
like. This is a test machine and isn't used for day to day activities.

Comment 9 Michael Fulbright 2003-02-06 20:26:40 UTC
I understand what you are saying - we haven't had a report of aspell hanging
like you are describing.  Did you install in English, and choose English as the
default language?



Comment 10 Michael Fratoni 2003-02-09 00:05:13 UTC
Yes, I installed in English, and chose English as the default language.

Have there been other reports of hangs during the package install phase?

Comment 11 Michael Fratoni 2003-02-09 03:05:37 UTC
I've now completed an additional 5 installs from the same media (on the smae
machine) without any issues at all. Unless others have seen the installer hang
during package installation, I'm inclined to consider this unreproducable.

Comment 12 Michael Fulbright 2003-02-11 17:38:26 UTC
I understand - I hope it continues to not be an issue.

I've dealt with alot of issues related to CDs and CD drives - they can be
frustrating at times.



Note You need to log in before you can comment on or make changes to this bug.