Bug 833085 - SELinux is preventing /usr/bin/vmnet-dhcpd from 'write' accesses on the directory /etc/vmware/vmnet8/dhcpd.
SELinux is preventing /usr/bin/vmnet-dhcpd from 'write' accesses on the direc...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:f568e4e6529c4b63a21517426f2...
:
: 833081 833083 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-18 10:39 EDT by stephane.hofman
Modified: 2012-06-19 05:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-18 11:32:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description stephane.hofman 2012-06-18 10:39:04 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.4.0-1.fc17.x86_64
time:           lun. 18 juin 2012 16:38:50 CEST

description:
:SELinux is preventing /usr/bin/vmnet-dhcpd from 'write' accesses on the directory /etc/vmware/vmnet8/dhcpd.
:
:*****  Plugin restorecon (94.8 confidence) suggests  *************************
:
:If you want to fix the label. 
:/etc/vmware/vmnet8/dhcpd default label should be vmware_sys_conf_t.
:Then you can run restorecon.
:Do
:# /sbin/restorecon -v /etc/vmware/vmnet8/dhcpd
:
:*****  Plugin catchall_labels (5.21 confidence) suggests  ********************
:
:If you want to allow vmnet-dhcpd to have write access on the dhcpd directory
:Then you need to change the label on /etc/vmware/vmnet8/dhcpd
:Do
:# semanage fcontext -a -t FILE_TYPE '/etc/vmware/vmnet8/dhcpd'
:where FILE_TYPE is one of the following: var_log_t, var_run_t, vmware_host_pid_t, vmware_host_tmp_t, tmp_t, vmware_log_t, vmware_sys_conf_t, root_t. 
:Then execute: 
:restorecon -v '/etc/vmware/vmnet8/dhcpd'
:
:
:*****  Plugin catchall (1.44 confidence) suggests  ***************************
:
:If you believe that vmnet-dhcpd should be allowed write access on the dhcpd directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep vmnet-dhcpd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:vmware_host_t:s0-s0:c0.c1023
:Target Context                unconfined_u:object_r:etc_t:s0
:Target Objects                /etc/vmware/vmnet8/dhcpd [ dir ]
:Source                        vmnet-dhcpd
:Source Path                   /usr/bin/vmnet-dhcpd
:Port                          <Inconnu>
:Host                          (removed)
:Source RPM Packages           
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-130.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.4.0-1.fc17.x86_64 #1 SMP
:                              Sun Jun 3 06:35:17 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    lun. 18 juin 2012 16:26:33 CEST
:Last Seen                     lun. 18 juin 2012 16:26:33 CEST
:Local ID                      35cf80ef-6264-46a7-bbf5-f2b266b9c200
:
:Raw Audit Messages
:type=AVC msg=audit(1340029593.155:45): avc:  denied  { write } for  pid=882 comm="vmnet-dhcpd" name="dhcpd" dev="sda1" ino=413548 scontext=system_u:system_r:vmware_host_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:etc_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1340029593.155:45): arch=x86_64 syscall=unlink success=no exit=EACCES a0=7f041558edc0 a1=7fff07e614d7 a2=7f0413330101 a3=27 items=0 ppid=726 pid=882 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=vmnet-dhcpd exe=/usr/bin/vmnet-dhcpd subj=system_u:system_r:vmware_host_t:s0-s0:c0.c1023 key=(null)
:
:Hash: vmnet-dhcpd,vmware_host_t,etc_t,dir,write
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-06-18 11:30:46 EDT
*** Bug 833083 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2012-06-18 11:30:52 EDT
*** Bug 833081 has been marked as a duplicate of this bug. ***
Comment 3 Miroslav Grepl 2012-06-18 11:32:32 EDT
Execute

# restorecon -R -v /etc/vmware

to fix labeling. Did you recreate this directory?
Comment 4 stephane.hofman 2012-06-19 04:58:40 EDT
No, I've not modified this directory....
Comment 5 stephane.hofman 2012-06-19 05:01:32 EDT
I've executed your command, and it's ok for now !!!

Thanks

Note You need to log in before you can comment on or make changes to this bug.