Bug 833096 - SELinux is preventing /usr/libexec/postfix/smtpd from 'read' accesses on the lnk_file /var/tmp.
SELinux is preventing /usr/libexec/postfix/smtpd from 'read' accesses on the ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:7eb2ca6e9c084c09a65dd2d1b39...
:
: 833097 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-18 11:01 EDT by Lester Petrie
Modified: 2012-06-18 11:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-18 11:22:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lester Petrie 2012-06-18 11:01:38 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.4.0-1.fc17.x86_64
time:           Mon 18 Jun 2012 10:56:54 AM EDT

description:
:SELinux is preventing /usr/libexec/postfix/smtpd from 'read' accesses on the lnk_file /var/tmp.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that smtpd should be allowed read access on the tmp lnk_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep smtpd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:postfix_smtpd_t:s0
:Target Context                system_u:object_r:tmp_t:s0
:Target Objects                /var/tmp [ lnk_file ]
:Source                        smtpd
:Source Path                   /usr/libexec/postfix/smtpd
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           postfix-2.9.2-2.fc17.x86_64
:Target RPM Packages           filesystem-3-2.fc17.x86_64
:Policy RPM                    selinux-policy-3.10.0-128.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.4.0-1.fc17.x86_64 #1 SMP
:                              Sun Jun 3 06:35:17 UTC 2012 x86_64 x86_64
:Alert Count                   3
:First Seen                    Mon 18 Jun 2012 10:45:19 AM EDT
:Last Seen                     Mon 18 Jun 2012 10:50:44 AM EDT
:Local ID                      6af50bea-1eef-4ea5-9935-66ea7cec7a73
:
:Raw Audit Messages
:type=AVC msg=audit(1340031044.466:194): avc:  denied  { read } for  pid=5613 comm="smtpd" name="tmp" dev="sdd5" ino=130860 scontext=system_u:system_r:postfix_smtpd_t:s0 tcontext=system_u:object_r:tmp_t:s0 tclass=lnk_file
:
:
:type=SYSCALL msg=audit(1340031044.466:194): arch=x86_64 syscall=stat success=no exit=EACCES a0=7fb5fa0504cb a1=7fff89ac6850 a2=7fff89ac6850 a3=7fff89ac65e0 items=0 ppid=1289 pid=5613 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=smtpd exe=/usr/libexec/postfix/smtpd subj=system_u:system_r:postfix_smtpd_t:s0 key=(null)
:
:Hash: smtpd,postfix_smtpd_t,tmp_t,lnk_file,read
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-06-18 11:11:35 EDT
*** Bug 833097 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2012-06-18 11:22:28 EDT
Should be fixed in the latest policy.

yum update selinux-policy-targeted

Note You need to log in before you can comment on or make changes to this bug.