Bug 833200 - [abrt] libnotify-0.7.5-1.fc17: g_return_if_fail_warning: Process /usr/bin/notify-send was killed by signal 5 (SIGTRAP)
[abrt] libnotify-0.7.5-1.fc17: g_return_if_fail_warning: Process /usr/bin/not...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libnotify (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
abrt_hash:158dffdfac0091d5151fddac6ad...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-18 17:03 EDT by Raphaël Flores
Modified: 2013-06-19 18:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-19 18:35:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: event_log (1.01 KB, text/plain)
2012-06-18 17:03 EDT, Raphaël Flores
no flags Details
File: backtrace (21.88 KB, text/plain)
2012-06-18 17:03 EDT, Raphaël Flores
no flags Details
File: coredump (8.68 MB, text/plain)
2012-06-18 17:05 EDT, Raphaël Flores
no flags Details
File: maps (5.03 KB, text/plain)
2012-06-18 17:05 EDT, Raphaël Flores
no flags Details
icone used by notify-send during crash. (9.09 KB, image/png)
2013-02-25 16:03 EST, Raphaël Flores
no flags Details
script that contains the cmdline (200 bytes, text/plain)
2013-02-25 16:30 EST, Michael Schwendt
no flags Details

  None (edit)
Description Raphaël Flores 2012-06-18 17:03:07 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/bin/notify-send -t 1000 -i '/home/rflores/T\xe9l\xe9chargements/Thunderbird/icone/Thunderbird_norm_modifie.png' 'Anne Tramut ' '[Quadrature_discut] Re :  Pi\xe8ces \xe0 conviction hier soir sur France3'
crash_function: g_return_if_fail_warning
executable:     /usr/bin/notify-send
kernel:         3.4.0-1.fc17.i686
pid:            2632
pwd:            /home/rflores
time:           lun. 18 juin 2012 19:41:09 CEST
uid:            1000
username:       rflores
var_log_messages: Jun 18 19:41:09 localhost abrt[2635]: Saved core dump of pid 2632 (/usr/bin/notify-send) to /var/spool/abrt/ccpp-2012-06-18-19:41:09-2632 (9105408 bytes)

backtrace:      Text file, 22407 bytes
event_log:      Binary file, 1030 bytes
maps:           Text file, 5152 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/rflores/1

core_backtrace:
:4a18cece7105bb73a4f2c3ad540803eb237e7543 0x4ebd1 g_logv libglib-2.0.so.0 -
:4a18cece7105bb73a4f2c3ad540803eb237e7543 0x4ed14 g_log libglib-2.0.so.0 -
:4a18cece7105bb73a4f2c3ad540803eb237e7543 0x4ed5e g_return_if_fail_warning libglib-2.0.so.0 -
:4a18cece7105bb73a4f2c3ad540803eb237e7543 0x78582 g_variant_new_string libglib-2.0.so.0 -
:4a18cece7105bb73a4f2c3ad540803eb237e7543 0x7cb90 - libglib-2.0.so.0 -
:4a18cece7105bb73a4f2c3ad540803eb237e7543 0x7deda - libglib-2.0.so.0 -
:4a18cece7105bb73a4f2c3ad540803eb237e7543 0x7dceb - libglib-2.0.so.0 -
:4a18cece7105bb73a4f2c3ad540803eb237e7543 0x7df4d g_variant_new_va libglib-2.0.so.0 -
:4a18cece7105bb73a4f2c3ad540803eb237e7543 0x7e002 g_variant_new libglib-2.0.so.0 -
:5531b5e0176d5ff2b88ade6aa53115ed1cb53418 0x34d5 notify_notification_show libnotify.so.4 -
:b0190834d6e9f2942603929b9735941724251f70 0x12bc - [exe] -

dso_list:
:/usr/lib/gconv/gconv-modules.cache glibc-2.15-37.fc17.i686 (Fedora Project) 1337719195
:/usr/lib/libgdk_pixbuf-2.0.so.0.2600.1 gdk-pixbuf2-2.26.1-1.fc17.i686 (Fedora Project) 1337719205
:/usr/lib/libc-2.15.so glibc-2.15-37.fc17.i686 (Fedora Project) 1337719195
:/usr/lib/libnotify.so.4.0.0 libnotify-0.7.5-1.fc17.i686 (Fedora Project) 1337719279
:/usr/lib/libgio-2.0.so.0.3200.3 glib2-2.32.3-1.fc17.i686 (Fedora Project) 1339608336
:/usr/lib/libgthread-2.0.so.0.3200.3 glib2-2.32.3-1.fc17.i686 (Fedora Project) 1339608336
:/usr/lib/librt-2.15.so glibc-2.15-37.fc17.i686 (Fedora Project) 1337719195
:/usr/lib/libresolv-2.15.so glibc-2.15-37.fc17.i686 (Fedora Project) 1337719195
:/usr/lib/libdl-2.15.so glibc-2.15-37.fc17.i686 (Fedora Project) 1337719195
:/usr/bin/notify-send libnotify-0.7.5-1.fc17.i686 (Fedora Project) 1337719279
:/usr/lib/libpthread-2.15.so glibc-2.15-37.fc17.i686 (Fedora Project) 1337719195
:/usr/lib/ld-2.15.so glibc-2.15-37.fc17.i686 (Fedora Project) 1337719195
:/usr/lib/libglib-2.0.so.0.3200.3 glib2-2.32.3-1.fc17.i686 (Fedora Project) 1339608336
:/usr/lib/libffi.so.5.0.10 libffi-3.0.10-2.fc17.i686 (Fedora Project) 1337719198
:/usr/lib/libgmodule-2.0.so.0.3200.3 glib2-2.32.3-1.fc17.i686 (Fedora Project) 1339608336
:/usr/lib/libpng15.so.15.10.0 libpng-2:1.5.10-1.fc17.i686 (Fedora Project) 1337719198
:/usr/lib/libz.so.1.2.5 zlib-1.2.5-6.fc17.i686 (Fedora Project) 1337719197
:/usr/lib/libm-2.15.so glibc-2.15-37.fc17.i686 (Fedora Project) 1337719195
:/usr/lib/libselinux.so.1 libselinux-2.1.10-3.fc17.i686 (Fedora Project) 1337719197
:/usr/lib/libgobject-2.0.so.0.3200.3 glib2-2.32.3-1.fc17.i686 (Fedora Project) 1339608336

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=1
:HOSTNAME=localhost.localdomain
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:QT_GRAPHICSSYSTEM_CHECKED=1
:IMSETTINGS_MODULE=none
:USER=rflores
:USERNAME=rflores
:MAIL=/var/spool/mail/rflores
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/rflores/.local/bin:/home/rflores/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/rflores
:XMODIFIERS=@im=none
:LANG=fr_FR.utf8
:GDM_LANG=fr_FR.utf8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/rflores
:SHLVL=1
:LOGNAME=rflores
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-CmK6wI1wqZ,guid=5db2a81c0265aba17595f1d80000000f
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/rflores
:DISPLAY=:0
:XAUTHORITY=/var/run/gdm/auth-for-rflores-JJTyT5/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/763,unix/unix:/tmp/.ICE-unix/763
:GNOME_KEYRING_CONTROL=/run/user/rflores/keyring-L7wDXC
:SSH_AUTH_SOCK=/run/user/rflores/keyring-L7wDXC/ssh
:GPG_AGENT_INFO=/run/user/rflores/keyring-L7wDXC/gpg:0:1
:LC_TIME=fr_FR.utf8
:LC_NUMERIC=fr_FR.utf8
:LC_MONETARY=fr_FR.utf8
:LC_MEASUREMENT=fr_FR.utf8
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:GIO_LAUNCHED_DESKTOP_FILE=/home/rflores/.local/share/applications/thunderbird.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=1440
:NO_AT_BRIDGE=1
:'MOZ_CRASHREPORTER_RESTART_ARG_0=/home/rflores/T\xc3\xa9l\xc3\xa9chargements/Thunderbird/thunderbird/thunderbird'
:MOZ_CRASHREPORTER_RESTART_ARG_1=
:'MOZ_CRASHREPORTER_DATA_DIRECTORY=/home/rflores/.thunderbird/Crash Reports'
:MOZ_LAUNCHED_CHILD=
:XRE_PROFILE_PATH=
:XRE_PROFILE_LOCAL_PATH=
:XRE_PROFILE_NAME=
:XRE_START_OFFLINE=
:NO_EM_RESTART=
:XUL_APP_FILE=
:XRE_BINARY_PATH=

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 23086                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       23086                23086                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:1:/home/rflores/.xsession-errors
:2:/home/rflores/.xsession-errors
:3:/home/rflores/.mozilla-thunderbird/rlcgxhbi.default/TestPilotErrorLog.log
:4:anon_inode:[eventfd]
:5:socket:[553918]
:6:/home/rflores/.mozilla-thunderbird/rlcgxhbi.default/.parentlock
:7:anon_inode:[eventfd]

smolt_data:
:
:
:Général
:=================================
:UUID: 79470c2e-ef65-47c4-ab97-43ddb7f79e06
:SE: Fedora release 17 (Beefy Miracle)
:Niveau d'exécution par défaut: Unknown
:Langue: fr_FR.utf8
:Plateforme: i686
:BogoMIPS: 5628.01
:Fabricant du processeurs: AuthenticAMD
:Modèle de processeur: AMD Athlon(tm) II X2 240 Processor
:Stepping du processeur: 2
:Famille de processeur: 16
:Modèle du processeur: 6
:Nombre de processeurs: 2
:Vitesse du processeur: 2800
:Mémoire du système: 2902
:Swap du système: 2047
:Fabricant: Gigabyte Technology Co., Ltd.
:Système: GA-MA74GM-S2H 
:Type d'ordinateur: Desktop
:Noyau: 3.4.0-1.fc17.i686
:SELinux activé: 1
:Stratégie SELinux: targeted
:SELinux strict: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Périphériques
:=================================
:(4098:30998:5208:20480) pci, pcieport, PCI/PCI, RS690 PCI to PCI Bridge (PCI Express Port 2)
:(4098:17297:5208:45058) pci, ahci, STORAGE, SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode]
:(4098:17302:5208:20484) pci, ehci_hcd, USB, SB7x0/SB8x0/SB9x0 USB EHCI Controller
:(4098:30993:5208:20480) pci, None, HOST/PCI, RS690 Host Bridge
:(4098:31001:5208:31001) pci, snd_hda_intel, MULTIMEDIA, Radeon X1200 Series Audio Controller
:(4098:30994:4098:30994) pci, None, PCI/PCI, RS690 PCI to PCI Bridge (Internal gfx)
:(4130:4612:0:0) pci, None, HOST/PCI, Family 10h Processor Link Control
:(4130:4609:0:0) pci, None, HOST/PCI, Family 10h Processor Address Map
:(4130:4608:0:0) pci, None, HOST/PCI, Family 10h Processor HyperTransport Configuration
:(4130:4611:0:0) pci, k10temp, HOST/PCI, Family 10h Processor Miscellaneous Control
:(4130:4610:0:0) pci, None, HOST/PCI, Family 10h Processor DRAM Controller
:(4332:33128:5208:57344) pci, r8169, ETHERNET, GA-EP45-DS5 Motherboard
:(4098:17308:5208:20482) pci, pata_atiixp, STORAGE, SB7x0/SB8x0/SB9x0 IDE Controller
:(4098:17285:5208:17285) pci, piix4_smbus, SERIAL, GA-MA770-DS3rev2.0 Motherboard
:(4098:17309:5208:20481) pci, None, PCI/ISA, SB7x0/SB8x0/SB9x0 LPC host controller
:(4098:17283:5208:40962) pci, snd_hda_intel, MULTIMEDIA, SBx00 Azalia (Intel HDA)
:(4098:17305:5208:20484) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
:(4098:17284:0:0) pci, None, PCI/PCI, SBx00 PCI to PCI Bridge
:(4204:33081:4204:0) pci, None, ETHERNET, N/A
:(4098:31086:5208:53248) pci, radeon, VIDEO, Radeon 2100
:(4098:17303:5208:20484) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
:(4098:17304:5208:20484) pci, ohci_hcd, USB, SB7x0 USB OHCI1 Controller
:(4098:17302:5208:20484) pci, ehci_hcd, USB, SB7x0/SB8x0/SB9x0 USB EHCI Controller
:(4098:17304:5208:20484) pci, ohci_hcd, USB, SB7x0 USB OHCI1 Controller
:(4098:17303:5208:20484) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
:
:
:Informations sur le système de fichiers
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda1 / ext4 4096 4096 4619724 3523471 3477212 1163264 1034694 1034694
:/dev/sda3 /home ext4 4096 4096 10218049 4479021 3967021 2564096 2540850 2540850
:/dev/sdb5 WITHHELD ext4 4096 4096 52929836 10112832 7463117 13254656 13146870 13146870
:/dev/sdc8 WITHHELD ext4 4096 4096 68298159 6557828 3139000 17096704 16908946 16908946
:
Comment 1 Raphaël Flores 2012-06-18 17:03:12 EDT
Created attachment 592744 [details]
File: event_log
Comment 2 Raphaël Flores 2012-06-18 17:03:14 EDT
Created attachment 592745 [details]
File: backtrace
Comment 3 Raphaël Flores 2012-06-18 17:05:10 EDT
Created attachment 592746 [details]
File: coredump
Comment 4 Raphaël Flores 2012-06-18 17:05:13 EDT
Created attachment 592747 [details]
File: maps
Comment 5 Fedora Admin XMLRPC Client 2013-02-24 05:38:01 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Michael Schwendt 2013-02-24 15:19:38 EST
> LANG=fr_FR.utf8

> #3  0x46285582 in g_variant_new_string (string=<optimized out>) at gvariant.c:1267
> No locals.
> #4  g_variant_new_string (string=0x959dd90 "/home/rflores/T\351l\351chargements/Thunderbird/icone/Thunderbird_norm_modifie.png") at gvariant.c:1264
>

How reproducible is it? Always? Just occasionally? Could you attach the PNG file that you've used? And perhaps also a shell-script file where the French characters are not escaped?
Comment 7 Raphaël Flores 2013-02-25 16:03:45 EST
Created attachment 702516 [details]
icone used by notify-send during crash.

Cannot reproduce the bug currently with notify-send 0.7.5.

What did you mean by: " And perhaps also a shell-script file where the French characters are not escaped?" ?
Comment 8 Michael Schwendt 2013-02-25 16:30:39 EST
Created attachment 702523 [details]
script that contains the cmdline

With that I referred to the "cmdline" mentioned in the original bug report, which I assumed made the problem reproducible for you. Parts of it failed during utf8 validation assertion (see comment 6) inside glib2. I've encoded the escaped characters properly, but running the cmdline is not sufficient to reproduce the crash.
Comment 9 Raphaël Flores 2013-02-28 17:57:37 EST
Yep, even with the correct cmd line, I'm not able to reproduce the crash today. But I'm wondering if it was not linked to the possibliy unmounted file system on which the image is store. Let's try...
Comment 10 Raphaël Flores 2013-02-28 18:10:27 EST
Nothing to do for the bug to be reproduced on my computer... /o\
Comment 11 Dan Mashal 2013-06-19 18:35:52 EDT
notification-daemon was updated so  I assume that fixed the problem.

Note You need to log in before you can comment on or make changes to this bug.