Bug 833319 - message for service-level option in subscription-manager register --help option should be modified
message for service-level option in subscription-manager register --help opti...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 5.9
Assigned To: Bryan Kearney
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-06-19 04:38 EDT by Shwetha Kallesh
Modified: 2013-01-07 22:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:55:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shwetha Kallesh 2012-06-19 04:38:33 EDT
Description of problem:

message for service-level option in subscription-manager register --help option should be modified

Version-Release number of selected component (if applicable):
[root@dhcp201-111 consumer]# rpm -qa | grep subscription-manager
subscription-manager-migration-data-1.11.1.1-1.git.2.c7fbafe.el5
subscription-manager-migration-1.0.4-1.git.3.1768f90.el5
subscription-manager-1.0.4-1.git.3.1768f90.el5
subscription-manager-gui-1.0.4-1.git.3.1768f90.el5
subscription-manager-firstboot-1.0.4-1.git.3.1768f90.el5

How reproducible:


Steps to Reproduce:

[root@dhcp201-111 consumer]# subscription-manager register --help | grep service
  --servicelevel=SERVICE_LEVEL
                        service level to apply to this system


  
Actual results:


Expected results:
--servicelevel=SERVICE_LEVEL
                        service level to apply to this system,only used
                        with --autosubscribe 

Additional info:
Comment 1 Bryan Kearney 2012-08-14 10:39:52 EDT
per discussion with Mreid, made the text:

system preference used when subscribing automatically
Comment 2 Matt Reid 2012-08-14 10:46:44 EDT
To expand on that, I'm hesitant to single out --autosubscribe, as I'm pretty sure the SL preference is also taken into account when auto-healing. 

"system preference used when subscribing automatically" fits on one line in the terminal, and matches up pretty closely with what we display in the gui when describing it (which is "Your system's service level preference is followed when subscribing automatically").
Comment 3 Bryan Kearney 2012-08-15 08:40:53 EDT
fixed in master at 404361ffab87c6306fb4aa1298ca6bd27db13a88
Comment 4 RHEL Product and Program Management 2012-08-15 08:57:17 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 5 Shwetha Kallesh 2012-08-17 07:38:27 EDT
Marking verified

RPM version:
[root@dhcp201-115 ~]# rpm -qa | grep subscription-manager
subscription-manager-firstboot-1.0.13-1.git.45.5cb55c8.el5
subscription-manager-1.0.13-1.git.45.5cb55c8.el5
subscription-manager-migration-data-1.11.2.3-1.git.0.861f9ba.el5
subscription-manager-gui-1.0.13-1.git.45.5cb55c8.el5
subscription-manager-migration-1.0.13-1.git.45.5cb55c8.el5


[root@dhcp201-115 ~]# subscription-manager register --help | grep servicelevel

--servicelevel=SERVICE_LEVEL
                        system preference used when subscribing automatically
Comment 7 errata-xmlrpc 2013-01-07 22:55:37 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.