Bug 833376 - Failed created app is not cleared from mongo and can not be destroyed
Failed created app is not cleared from mongo and can not be destroyed
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
1.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Rajat Chopra
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-19 06:49 EDT by Xiaoli Tian
Modified: 2012-06-25 14:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-25 14:27:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xiaoli Tian 2012-06-19 06:49:39 EDT
Description of problem:
If the app failed to create like bug 832745 said, the failed app data is not removed from mongo, and can not be destoryed via client.

It shows in rhc-domain-show, but when you access it , it said the app is not available.

When you try to destroy it, it said the app does not exist.


Version-Release number of selected component (if applicable):
devenv_1855

How reproducible:
Always

Steps to Reproduce:
1.Failed to create app with steps in bug 832745
2.rhc domain show
3.Access the app in above domain infor
4.Try to destory the app above

Actual results:

Step 3 and step 4 fail

Expected results:
The information should not be listed in rhc domain show, it should be cleared from mongo

Additional info:
Broker log:
DEBUG: rpc_client.custom_request('cartridge_do', {:action=>"deconfigure", :args=>"'b69f0e064b' 'freedom3' 'b69f0e064bf64e88abc75bb14180668b'", :cartridge=>"php-5.3"}, @id, {'identity' => @id})
DEBUG: [#<MCollective::RPC::Result:0x7f1859680830 @results={:sender=>"ip-10-62-91-176", :statusmsg=>"OK", :data=>{:exitcode=>0, :output=>"Waiting for stop to finish\n"}, :statuscode=>0}, @action="cartridge_do", @agent="libra">]
DEBUG: Cartridge command php-5.3::deconfigure exitcode = 0
MongoDataStore.save(CloudUser, xtian+b105@redhat.com, xtian+b105@redhat.com, #hidden)

DEBUG: rpc_exec_direct: rpc_client=#<MCollective::RPC::Client:0x7f185966b6b0>
DEBUG: rpc_client.custom_request('cartridge_do', {:action=>"deconfigure", :args=>"'b3dd6a8997' 'freedom3' 'b3dd6a8997eb409c83764530a2f0342d'", :cartridge=>"php-5.3"}, @id, {'identity' => @id})
DEBUG: [#<MCollective::RPC::Result:0x7f185961ffa8 @results={:sender=>"ip-10-62-91-176", :statusmsg=>"OK", :data=>{:exitcode=>0, :output=>"Waiting for stop to finish\n"}, :statuscode=>0}, @action="cartridge_do", @agent="libra">]
DEBUG: Cartridge command php-5.3::deconfigure exitcode = 0
MongoDataStore.save(CloudUser, xtian+b105@redhat.com, xtian+b105@redhat.com, #hidden)

DEBUG: rpc_exec_direct: rpc_client=#<MCollective::RPC::Client:0x7f18596afef0>
DEBUG: rpc_client.custom_request('cartridge_do', {:action=>"deconfigure", :args=>"'854dae0d92' 'freedom3' '854dae0d923545c690f9705895d3a7e7'", :cartridge=>"php-5.3"}, @id, {'identity' => @id})
DEBUG: [#<MCollective::RPC::Result:0x7f18597a1408 @results={:sender=>"ip-10-62-91-176", :statusmsg=>"OK", :data=>{:exitcode=>0, :output=>"Waiting for stop to finish\n"}, :statuscode=>0}, @action="cartridge_do", @agent="libra">]
DEBUG: Cartridge command php-5.3::deconfigure exitcode = 0
MongoDataStore.save(CloudUser, xtian+b105@redhat.com, xtian+b105@redhat.com, #hidden)

DEBUG: rpc_exec_direct: rpc_client=#<MCollective::RPC::Client:0x7f185976bc90>
DEBUG: rpc_client.custom_request('cartridge_do', {:action=>"deconfigure", :args=>"'fbcdc69857' 'freedom3' 'fbcdc69857254724b3bb94f7444903ed'", :cartridge=>"php-5.3"}, @id, {'identity' => @id})
DEBUG: [#<MCollective::RPC::Result:0x7f18596e6608 @results={:sender=>"ip-10-62-91-176", :statusmsg=>"OK", :data=>{:exitcode=>0, :output=>"Waiting for stop to finish\n"}, :statuscode=>0}, @action="cartridge_do", @agent="libra">]
DEBUG: Cartridge command php-5.3::deconfigure exitcode = 0
MongoDataStore.save(CloudUser, xtian+b105@redhat.com, xtian+b105@redhat.com, #hidden)

DEBUG: Deconfiguring embedded application 'haproxy-1.4' in application 'phpapp5' on node 'ip-10-62-91-176'
DEBUG: rpc_exec_direct: rpc_client=#<MCollective::RPC::Client:0x7f18596c4e18>
DEBUG: rpc_client.custom_request('cartridge_do', {:action=>"deconfigure", :args=>"'phpapp5' 'freedom3' 'c0d1bec318104c7e9569cf9d29d35ec6'", :cartridge=>"embedded/haproxy-1.4"}, @id, {'identity' => @id})
DEBUG: [#<MCollective::RPC::Result:0x7f1859640f78 @results={:sender=>"ip-10-62-91-176", :statusmsg=>"OK", :data=>{:exitcode=>0, :output=>"/usr/libexec/stickshift/cartridges/embedded/haproxy-1.4/info/hooks/deconfigure: line 62: kill: (14315) - No such process\nSSH_KEY_REMOVE: \n"}, :statuscode=>0}, @action="cartridge_do", @agent="libra">]

DEBUG: Cartridge command embedded/haproxy-1.4::deconfigure exitcode = 0
MongoDataStore.save(CloudUser, xtian+b105@redhat.com, xtian+b105@redhat.com, #hidden)

DEBUG: rpc_exec_direct: rpc_client=#<MCollective::RPC::Client:0x7f18597a0f30>
DEBUG: rpc_client.custom_request('cartridge_do', {:action=>"deconfigure", :args=>"'phpapp5' 'freedom3' 'c0d1bec318104c7e9569cf9d29d35ec6'", :cartridge=>"php-5.3"}, @id, {'identity' => @id})
DEBUG: [#<MCollective::RPC::Result:0x7f18596fbc88 @results={:sender=>"ip-10-62-91-176", :statusmsg=>"OK", :data=>{:exitcode=>0, :output=>"Waiting for stop to finish\n"}, :statuscode=>0}, @action="cartridge_do", @agent="libra">]
DEBUG: Cartridge command php-5.3::deconfigure exitcode = 0
MongoDataStore.save(CloudUser, xtian+b105@redhat.com, xtian+b105@redhat.com, #hidden)

MongoDataStore.save(Application, xtian+b105@redhat.com, phpapp5, #hidden)

Completed 500 Internal Server Error in 96585ms
StickShift::UserException (Application limit has reached for 'xtian+b105@redhat.com')

Or see https://bugzilla.redhat.com/show_bug.cgi?id=800188#c20,
https://bugzilla.redhat.com/show_bug.cgi?id=800188#c21
Comment 1 John Poelstra 2012-06-19 13:39:49 EDT
fixing today
Comment 2 Rajat Chopra 2012-06-19 16:53:39 EDT
pull request#147
rev#4897aad609684956e37a04f1e84be9c3d9280b85
Comment 3 Johnny Liu 2012-06-20 05:05:13 EDT
Verified this bug with devenv_1589, and PASS.

$ rhc-create-app -a phptest -t php-5.3 -px -l new -s -n
Creating application: phptest in newnew
Problem reported from server. Response code was 406.
Re-run with -d for more information.

MESSAGES:
Failed to create application phptest due to: Failed: Either application limit has already reached or domain doesn't exist for 'new'


$ rhc domain show -l new -px

User Info
=========
Namespace: newnew
  RHLogin: new


Application Info
================
No applications found.  You can use 'rhc app create' to create new applications.

Note You need to log in before you can comment on or make changes to this bug.