Bug 833392 - yum update fails with transaction check errror
yum update fails with transaction check errror
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-19 07:47 EDT by Stoyan Tsalev
Modified: 2014-01-21 18:22 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-19 14:24:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
List of repositories in use (1.98 KB, text/plain)
2012-06-19 07:50 EDT, Stoyan Tsalev
no flags Details

  None (edit)
Description Stoyan Tsalev 2012-06-19 07:47:08 EDT
Description of problem:


Version-Release number of selected component (if applicable):
[root@localhost ~]# yum --version
3.4.3
  Installed: rpm-4.9.1.3-7.fc17.x86_64 at 2012-06-04 17:30
  Built    : Fedora Project at 2012-05-07 10:05
  Committed: Panu Matilainen <pmatilai@redhat.com> at 2012-05-07

  Installed: yum-3.4.3-26.fc17.noarch at 2012-06-11 18:34
  Built    : Fedora Project at 2012-06-07 15:50
  Committed: Zdenek Pavlas <zpavlas at redhat.com> at 2012-06-07


How reproducible: 


Steps to Reproduce:
1. Use yum or Apper to apply the current updates
2. 
3.
  
Actual results:
Transaction error, package installation is aborted.

Expected results:
Transation completes without error, packages installed.


Additional info:

ERROR with transaction check vs depsolve:
perl(ExtUtils::ParseXS) is needed by perl-devel-4:5.14.2-212.fc17.x86_64
systemtap-sdt-devel is needed by perl-devel-4:5.14.2-212.fc17.x86_64
Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum
** Found 15 pre-existing rpmdb problem(s), 'yum check' output follows:
ICAClient-12.1.0-0.x86_64 has missing requires of nspluginwrapper
curl-7.24.0-4.fc17.x86_64 has missing requires of libcurl = ('0', '7.24.0', '4.fc17')
perl-ExtUtils-MakeMaker-6.62-2.fc17.noarch has missing requires of perl(ExtUtils::Manifest)
perl-ExtUtils-MakeMaker-6.62-2.fc17.noarch has missing requires of perl(Test::Harness)
4:perl-devel-5.14.2-211.fc17.x86_64 has missing requires of perl(ExtUtils::ParseXS)
4:perl-devel-5.14.2-211.fc17.x86_64 has missing requires of systemtap-sdt-devel
redhat-lsb-4.1-4.fc17.x86_64 has missing requires of redhat-lsb-core(x86-64) = ('0', '4.1', None)
redhat-lsb-cxx-4.1-4.fc17.x86_64 has missing requires of redhat-lsb-core(x86-64) = ('0', '4.1', None)
redhat-lsb-desktop-4.1-4.fc17.x86_64 has missing requires of redhat-lsb-core(x86-64) = ('0', '4.1', None)
redhat-lsb-languages-4.1-4.fc17.x86_64 has missing requires of perl(CGI)
redhat-lsb-languages-4.1-4.fc17.x86_64 has missing requires of perl(CPAN)
redhat-lsb-languages-4.1-4.fc17.x86_64 has missing requires of perl(Test::Harness)
redhat-lsb-languages-4.1-4.fc17.x86_64 has missing requires of redhat-lsb-core(x86-64) = ('0', '4.1', None)
redhat-lsb-printing-4.1-4.fc17.x86_64 has missing requires of redhat-lsb-core(x86-64) = ('0', '4.1', None)
sssd-1.8.4-13.fc17.x86_64 has missing requires of sssd-client(x86-64) = ('0', '1.8.4', '13.fc17')
Your transaction was saved, rerun it with:
 yum load-transaction /tmp/yum_save_tx.2012-06-19.14-44.dyfOuK.yumtx
Comment 1 Stoyan Tsalev 2012-06-19 07:50:38 EDT
Created attachment 592921 [details]
List of repositories in use

yum repolist
Comment 2 James Antill 2012-06-19 14:24:57 EDT
> ** Found 15 pre-existing rpmdb problem(s), 'yum check' output follows:

Fix these and yum will be happy again.

Note You need to log in before you can comment on or make changes to this bug.