This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 833420 - [Storage] Wrong CanDoAction message when trying to remove template's disk from the DISKS tab (UI get stuck because of it)
[Storage] Wrong CanDoAction message when trying to remove template's disk fro...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.1.0
Assigned To: Daniel Erez
Leonid Natapov
storage
:
: 828721 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-19 08:55 EDT by Leonid Natapov
Modified: 2016-02-10 11:42 EST (History)
14 users (show)

See Also:
Fixed In Version: SI8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:03:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leonid Natapov 2012-06-19 08:55:51 EDT
[Storage] Can't remove template's disk from the DISKS tab because engine sends wrong message to the UI. UI get stuck because of it.

When trying to remove disk that belongs to template from the DISKS tab UI get stuk. it happens because the engine sends to UI wrong CanDoAction.
Here is the engine log.
-------------------------
2012-06-19 15:18:07,056 WARN  [org.ovirt.engine.core.bll.RemoveDiskCommand] (ajp--0.0.0.0-8009-20) CanDoAction of action RemoveDisk failed. R
easons:VAR__ACTION__REMOVE,VAR__TYPE__VM_DISK,ACTION_TYPE_FAILED_STOARGE_DOMAIN_IS_WRONG
2012-06-19 15:18:07,058 INFO  [org.ovirt.engine.core.bll.RemoveDiskCommand] (ajp--0.0.0.0-8009-20) Lock freed to object EngineLock [exclusive
Locks= key: 6905226d-9b64-4ea4-ab7e-f5aa62e0359f value: DISK
, sharedLocks= key: e7167039-9101-45ba-8365-1b905efd6a7b value: TEMPLATE
----------------------

The storage domain is OK. CanDoAction should be can't remove last tepmplate's disk.


How to reproduce:
1.Create VM.
2.Create template from this VM.
3.Go to disks tab and try to remove disk that belongs to template.
Comment 1 Maor 2012-06-19 10:24:36 EDT
I didn't managed to reproduce the froze GUI bug on the master (I assume it is already fixed in the GUI - derez can you please verify it)

Regarding the wrong message, GUI should send the engine the storage id which the disk are meant to be removed from.
The storage id the engine gets from the GUI now is null.

Probably the suggested solution is that GUI will send a storage id list for all the storages the disk should be removed from.
Comment 2 Daniel Erez 2012-06-24 02:20:34 EDT
Template disk removal should be disabled from Disks main-tab.
commit c60c316aa020c8e8d44c1ef1c0f18b99416bfcc2
Comment 3 Leonid Natapov 2012-06-26 10:49:24 EDT
The problem still exist in si7.
Comment 4 Leonid Natapov 2012-07-01 10:35:29 EDT
fixed. si8
Comment 5 Asaf Shakarchi 2012-07-04 10:18:27 EDT
*** Bug 828721 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.