Bug 833495 - Updating device-mapper-event to 1.02.67-2.el5 or later "WARNING: The running demeventd instance is too old"
Updating device-mapper-event to 1.02.67-2.el5 or later "WARNING: The running ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: device-mapper (Show other bugs)
5.8
All Linux
medium Severity medium
: rc
: ---
Assigned To: Petr Rockai
Cluster QE
: Patch
Depends On:
Blocks: 1002709 953612
  Show dependency treegraph
 
Reported: 2012-06-19 11:22 EDT by John Ruemker
Modified: 2013-10-06 21:31 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 953612 (view as bug list)
Environment:
Last Closed: 2013-10-06 21:31:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Ruemker 2012-06-19 11:22:12 EDT
Description of problem: When updating from a version of device-mapper-event prior to 1.02.67-2.el5 to that version or later results in a warning:

  WARNING: The running dmeventd instance is too old.
  Protocol version 0 (required: 1). Action cancelled.

This occurs when the %post script of the rpm attempts to restart the daemon with 'dmeventd -R'.  This fails because in 5.8 we introduced protocol checking in restart:

  http://www.redhat.com/archives/lvm-devel/2011-March/msg00124.html

The result of the protocol version check failing is two-fold:

a) The old version of dmeventd is left running, and
b) The package update of device-mapper-event will fail, leaving both versions installed in the rpm database:

# yum update device-mapper
Loaded plugins: downloadonly, rhnplugin, security
Skipping security plugin, no data
Setting up Update Process
Resolving Dependencies
Skipping security plugin, no data
--> Running transaction check
--> Processing Dependency: device-mapper = 1.02.63-4.el5 for package: device-mapper-event
---> Package device-mapper.i386 0:1.02.67-2.el5 set to be updated
---> Package device-mapper.x86_64 0:1.02.67-2.el5 set to be updated
--> Running transaction check
---> Package device-mapper-event.x86_64 0:1.02.67-2.el5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=========================================================================================================================================================================================
 Package                                          Arch                                Version                                    Repository                                         Size
=========================================================================================================================================================================================
Updating:
 device-mapper                                    i386                                1.02.67-2.el5                              rhel-x86_64-server-5                              798 k
 device-mapper                                    x86_64                              1.02.67-2.el5                              rhel-x86_64-server-5                              830 k
Updating for dependencies:
 device-mapper-event                              x86_64                              1.02.67-2.el5                              rhel-x86_64-server-5                               24 k

Transaction Summary
=========================================================================================================================================================================================
Install       0 Package(s)
Upgrade       3 Package(s)

Total download size: 1.6 M
Is this ok [y/N]: y
Downloading Packages:
(1/3): device-mapper-event-1.02.67-2.el5.x86_64.rpm                                                                                                               |  24 kB     00:00     
(2/3): device-mapper-1.02.67-2.el5.i386.rpm                                                                                                                       | 798 kB     00:00     
(3/3): device-mapper-1.02.67-2.el5.x86_64.rpm                                                                                                                     | 830 kB     00:00     
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                    1.1 MB/s | 1.6 MB     00:01     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating       : device-mapper                                                                                                                                                     1/6 
  Updating       : device-mapper                                                                                                                                                     2/6 
  Updating       : device-mapper-event                                                                                                                                               3/6 
WARNING: The running dmeventd instance is too old.
Protocol version 0 (required: 1). Action cancelled.
Non-fatal POSTIN scriptlet failure in rpm package device-mapper-event-1.02.67-2.el5.x86_64
error: %post(device-mapper-event-1.02.67-2.el5.x86_64) scriptlet failed, exit status 1
  Cleanup        : device-mapper                                                                                                                                                     4/6 
  Cleanup        : device-mapper                                                                                                                                                     5/6 
rpm -q device-mapper
Updated:
  device-mapper.i386 0:1.02.67-2.el5                                                         device-mapper.x86_64 0:1.02.67-2.el5                                                        

Dependency Updated:
  device-mapper-event.x86_64 0:1.02.67-2.el5                                                                                                                                             

Complete!
[root@jrummy5-64 ~]# rpm -q device-mapper
device-mapper-1.02.67-2.el5
device-mapper-1.02.67-2.el5
[root@jrummy5-64 ~]# rpm -q device-mapper-event
device-mapper-event-1.02.63-4.el5
device-mapper-event-1.02.67-2.el5


Any customer updating from pre-5.8 to 5.8 or later and having dmeventd already running will run into this situation. 

Considering there weren't actually any protocol changes other than the version information (that I can tell), can we perhaps relax the check for now and not make it a fatal error if we detect a mismatch, but rather just report a warning and carry on?  I'm attaching a patch to this effect. 

Version-Release number of selected component (if applicable): 1.02.67-2.el5


How reproducible: Always


Steps to Reproduce:
1. Ensure you are running device-mapper-event prior to 1.02.67-2.el5
2. Create a snapshot logical volume or other device that will result in dmeventd running
3. Update to device-mapper-event-1.02.67-2.el5 or later
  
Actual results: Update fails, leaving old and new versions installed in rpm database.  Old version of dmeventd is still running.


Expected results: Update succeeds, and daemon is restarted successfully.
Comment 2 RHEL Product and Program Management 2012-06-19 11:41:09 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2013-05-01 03:06:39 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 5 Andrius Benokraitis 2013-10-06 21:31:54 EDT
This Bugzilla has been reviewed by Red Hat and is not planned on being addressed in Red Hat Enterprise Linux 5, and therefore will be closed. If this bug is critical to production systems, please contact your Red Hat support representative and provide sufficient business justification.

Note You need to log in before you can comment on or make changes to this bug.