Bug 833647 - some contents of Bugzilla::Extension::ExternalBugs::WebService module document are not accurate
some contents of Bugzilla::Extension::ExternalBugs::WebService module documen...
Status: CLOSED DUPLICATE of bug 840355
Product: Bugzilla
Classification: Community
Component: Documentation (Show other bugs)
4.2
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-19 22:45 EDT by Tony Fu
Modified: 2013-06-23 21:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-31 03:41:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tony Fu 2012-06-19 22:45:00 EDT
Description of problem:


Some contents of Bugzilla::Extension::ExternalBugs::WebService module document are not accurate at https://bugzilla.redhat.com/docs/en/html/api/extensions/ExternalBugs/lib/WebService.html

To point out a few of those incorrect info:
1. the function to delete an external tracker bug is remove_external_bug() rather than delete_external_bug()
2. the parameter of external bugzilla type is "ext_type_id", not "ext_bz_type_id"

And there are some other incorrect information around there as well.
Comment 1 Simon Green 2012-06-20 19:45:41 EDT
(In reply to comment #0)
> To point out a few of those incorrect info:
> 1. the function to delete an external tracker bug is remove_external_bug()
> rather than delete_external_bug()

I thought I had fixed this before the release, but it seems I didn't.

> And there are some other incorrect information around there as well.

Can you please let me know what other information is incorrect, so I can fix it. I think it is important that the documentation is correct, so am happy to fix this ASAP.

  -- simon
Comment 2 Tony Fu 2012-06-20 21:24:26 EDT
> Can you please let me know what other information is incorrect, so I can fix
> it. I think it is important that the documentation is correct, so am happy
> to fix this ASAP.
> 
1. param "ext_bz_type_url" and "ext_bz_type_description" should be "ext_type_url", and "ext_type_description" respectively ?
2. for delete_external_bug() (remove_external_bug()), it says "At least one of ext_desciption, ext_priority or ext_status must be specified. ".  I believe it is not true.

Those are the incorrect info I came across and I can't say it is a comprehensive list.
Comment 3 Simon Green 2012-07-31 03:41:16 EDT
Now idea why this one wasn't picked up for Bugzilla 4.2-4 but the duplicate was.

*** This bug has been marked as a duplicate of bug 840355 ***
Comment 4 Simon Green 2012-07-31 03:42:38 EDT
That was meant to read "No idea".

Note You need to log in before you can comment on or make changes to this bug.