Bug 833652 - add new make feature does't work from show.cgi
add new make feature does't work from show.cgi
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Hardware Catalog (Show other bugs)
6.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tony Fu
: Reopened
: 836128 (view as bug list)
Depends On:
Blocks: 837717
  Show dependency treegraph
 
Reported: 2012-06-19 23:34 EDT by QinXie
Modified: 2012-11-15 22:03 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-15 22:03:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description QinXie 2012-06-19 23:34:26 EDT
new make can't be added through the "Add a New Make"

Vendor entered make as "SuperStorage Server", and catalog reported it as "invalid make"

When I try to add this new make name with edit function:
1. click edit link at the right hand;
2. click "Add a New Make" option button and input "SuperStorage Server" in text field;
3. click "save change" button;
4. not happned, catalog still reported "invalid make"
Comment 1 Tony Fu 2012-06-20 00:02:10 EDT
(In reply to comment #0)
> new make can't be added through the "Add a New Make"
> 
> Vendor entered make as "SuperStorage Server", and catalog reported it as
> "invalid make"
> 
> When I try to add this new make name with edit function:
> 1. click edit link at the right hand;
> 2. click "Add a New Make" option button and input "SuperStorage Server" in
> text field;
> 3. click "save change" button;
> 4. not happned, catalog still reported "invalid make"

If you add a new make via the cert's page, it just adds the new make to that cert only.  Then catalog will check if the newly added make is valid make name based on the make list in hwcert db.  In order to make the "invalid make" disappear, you need to use "admin" page to add the new make for the vendor (in your case, you need to add "SuperStorage Server" make to "Super Micro Computer, Inc." vednor via admin page.)
Comment 2 Rob Landry 2012-06-20 10:10:39 EDT
I think we can improve the UI by allowing reviewers to confirm the addition of a make directly in the certification.  As it sits, add new make in the certify doesn't actually add a new make it only sets the whiteboard.  This will simplify and clarify the experience.
Comment 3 Tony Fu 2012-06-20 21:37:08 EDT
Add a feature to allow reviewers to approve the new make as invalid make (add the new make into makes table) in show.cgi page.

Move this bug to hybrid5.
Comment 4 Tony Fu 2012-06-21 03:30:12 EDT
Created attachment 593373 [details]
add a checkbox for reviewers to approve a new make as a valid make via cert page

Reviewers can select "Approve it as a valid make" checkbox to mark a make as a valid make
Comment 5 Tony Fu 2012-07-09 23:32:50 EDT
*** Bug 836128 has been marked as a duplicate of this bug. ***
Comment 6 Rob Landry 2012-08-20 13:36:36 EDT
Is there a test site with this patch?
Comment 7 Tony Fu 2012-11-01 03:31:10 EDT
Verified in web2
Comment 8 Tony Fu 2012-11-15 22:03:42 EST
Verified.

Note You need to log in before you can comment on or make changes to this bug.