Bug 833671 - [whql][Serial] BSOD with error code "C4" happened in many jobs for serial whql on HCK
[whql][Serial] BSOD with error code "C4" happened in many jobs for serial wh...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Gal Hammer
Virtualization Bugs
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-20 02:25 EDT by dawu
Modified: 2013-02-21 05:39 EST (History)
9 users (show)

See Also:
Fixed In Version: virtio-win-prewhql-0.1-51
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:39:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
HCK-serial-BSOD-C4 (24.79 KB, image/png)
2012-06-20 02:29 EDT, dawu
no flags Details

  None (edit)
Description dawu 2012-06-20 02:25:15 EDT
Description of problem:
BSOD with error code "C4" happened in many jobs for serial whql on HCK.

Version-Release number of selected component (if applicable):
kernel-2.6.32-278.el6.x86_64
qemu-kvm-0.12.1.2-2.295.el6.x86_64
virtio-win-prewhql-0.1-29

How reproducible:
always

Steps to Reproduce:

CLI:
/usr/libexec/qemu-kvm -m 6G -smp 4 -cpu cpu64-rhel6,+x2apic -usbdevice tablet -drive file=win2k8-r2-serial.raw,format=raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -netdev tap,sndbuf=0,id=hostnet0,script=/etc/qemu-ifup0,downscript=no -device e1000,netdev=hostnet0,mac=00:10:06:16:78:15,bus=pci.0,addr=0x4,id=net0 -uuid 33940eb2-8b99-4e30-902e-a52d154ae7ae -rtc base=localtime,clock=host,driftfix=slew -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win2k8-R2-serial,server,nowait -mon chardev=111a,mode=readline -name win2k8-R2-serial -vnc :1 -device virtio-serial-pci,id=virtio-serial0,max_ports=16,bus=pci.0,addr=0x5 -chardev socket,id=channel0,host=127.0.0.1,port=12345,server,nowait -device virtserialport,chardev=channel0,nr=1,bus=virtio-serial0.0,name=com.redhat.rhevm.vdsm -monitor stdio


1. Run jobs as followings:
   206  Device Install Check for Other Device Stability(Certification)
   207  Device Install Check for File System Consistency(Certification)
   1710 Wdf Fault Injection Logo Test
   2000 Device Path Exerciser Test (Certification)
   2019 Reinstall with IO Before and After(Certification)
   2042 Plug and Play Driver Test(Certification)
   2050 Concurrent Hardware and Operating System(CHOAS) Test(Certification)

  
Actual results:
BSOD Of "C4" happened in above jobs,please refer to the attached "HCK-serial-BSOD-C4.png".

Expected results:
Job should pass without any BSOD.

Additional info:
Comment 1 dawu 2012-06-20 02:29:39 EDT
Created attachment 593136 [details]
HCK-serial-BSOD-C4
Comment 3 dawu 2012-06-20 02:37:29 EDT
kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

DRIVER_VERIFIER_DETECTED_VIOLATION (c4)
A device driver attempting to corrupt the system has been caught.  This is
because the driver was specified in the registry as being suspect (by the
administrator) and the kernel has enabled substantial checking of this driver.
If the driver attempts to corrupt the system, bugchecks 0xC4, 0xC1 and 0xA will
be among the most commonly seen crashes.
Arguments:
Arg1: 0000000000000062, A driver has forgotten to free its pool allocations prior to unloading.
Arg2: fffffa80069118e8, name of the driver having the issue.
Arg3: fffffa8006911720, verifier internal structure with driver information.
Arg4: 0000000000000040, total # of (paged+nonpaged) allocations that weren't freed.
	Type !verifier 3 drivername.sys for info on the allocations
	that were leaked that caused the bugcheck.

Debugging Details:
------------------


BUGCHECK_STR:  0xc4_62

IMAGE_NAME:  vioser.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  4fd8928f

MODULE_NAME: vioser

FAULTING_MODULE: fffff88002800000 vioser

DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT

PROCESS_NAME:  System

CURRENT_IRQL:  2

LAST_CONTROL_TRANSFER:  from fffff800019583dc to fffff800014d21c0

STACK_TEXT:  
fffff880`01fd1768 fffff800`019583dc : 00000000`000000c4 00000000`00000062 fffffa80`069118e8 fffffa80`06911720 : nt!KeBugCheckEx
fffff880`01fd1770 fffff800`0196754a : 00000000`00000001 00000000`00000000 fffff880`02800000 00000000`00000001 : nt!VerifierBugCheckIfAppropriate+0x3c
fffff880`01fd17b0 fffff800`015bb970 : 00000000`00000000 00000000`00000000 fffff880`01ece180 00000000`00000000 : nt!VfPoolCheckForLeaks+0x4a
fffff880`01fd17f0 fffff800`018813ae : fffffa80`06911830 00000000`00000000 00000000`00000000 00000000`00000018 : nt!VfTargetDriversRemove+0x160
fffff880`01fd1890 fffff800`018a5e03 : 00000000`00000000 00000000`000e0082 00000000`00000000 00000000`00000001 : nt!VfDriverUnloadImage+0x2e
fffff880`01fd18c0 fffff800`018a627d : 00000000`00000000 fffffa80`06911830 00000000`00000000 00000000`00010200 : nt!MiUnloadSystemImage+0x283
fffff880`01fd1930 fffff800`019477f1 : 00000000`00000000 00000000`00000000 fffffa80`04efa360 00000000`00000018 : nt!MmUnloadSystemImage+0x4d
fffff880`01fd1970 fffff800`014db3e4 : 00000000`00000000 00000000`00000000 fffffa80`04efa360 fffff800`01802965 : nt!IopDeleteDriver+0x41
fffff880`01fd19a0 fffff800`017380c9 : 00000000`00000000 fffffa80`06bd1160 fffffa80`04efa4b0 fffffa80`06bd1130 : nt!ObfDereferenceObject+0xd4
fffff880`01fd1a00 fffff800`014db3e4 : 00000000`00000000 fffff8a0`01251890 00000000`00000000 00000000`00000001 : nt!IopDeleteDevice+0x49
fffff880`01fd1a30 fffff800`018a8662 : 00000000`00000000 fffffa80`06bd8410 fffff8a0`04e99d01 fffff8a0`04e99d00 : nt!ObfDereferenceObject+0xd4
fffff880`01fd1a90 fffff800`01948e44 : 00000000`00000000 fffffa80`81000000 00000000`00000000 fffffa80`06bd1160 : nt!PnpUnlinkDeviceRemovalRelations+0x112
fffff880`01fd1ae0 fffff800`019493ac : fffff880`00000000 00000000`00010200 fffff880`01fd1c00 00000000`00000000 : nt!PnpProcessQueryRemoveAndEject+0xd24
fffff880`01fd1c20 fffff800`0183264e : 00000000`00000000 fffffa80`074bd520 fffff8a0`05000130 fffff800`0166f200 : nt!PnpProcessTargetDeviceEvent+0x4c
fffff880`01fd1c50 fffff800`014db851 : fffff800`01737760 fffff8a0`04e99d00 fffff800`0166f2d8 fffffa80`04ef6b50 : nt! ?? ::NNGAKEGL::`string'+0x5ab8b
fffff880`01fd1cb0 fffff800`01768e6a : cccccccc`cccccccc fffffa80`04ef6b50 00000000`00000080 fffffa80`04e9eb30 : nt!ExpWorkerThread+0x111
fffff880`01fd1d40 fffff800`014c2f06 : fffff880`01e5d180 fffffa80`04ef6b50 fffff880`01e67fc0 8a10ffc8`8b48f841 : nt!PspSystemThreadStartup+0x5a
fffff880`01fd1d80 00000000`00000000 : fffff880`01fd2000 fffff880`01fcc000 fffff880`01fd16d0 00000000`00000000 : nt!KxStartSystemThread+0x16


STACK_COMMAND:  kb

FOLLOWUP_NAME:  MachineOwner

FAILURE_BUCKET_ID:  X64_0xc4_62_VRF_IMAGE_vioser.sys

BUCKET_ID:  X64_0xc4_62_VRF_IMAGE_vioser.sys

Followup: MachineOwner
---------
Comment 7 Mike Cao 2012-12-27 00:24:39 EST
This bug still exists in virtio-win-prewhql-49 
This bug must fix if we want to pass whql certification over win8/win2012 platform
Comment 10 Mike Cao 2013-01-15 06:39:59 EST
Hi, Gal 

The bug still existed in build 50 ,any updates ?

Thanks
Mike
Comment 11 Gal Hammer 2013-01-15 08:07:33 EST
The fix was pushed to the git repo today (15/1). It should be included in the next build.
Comment 12 Mike Cao 2013-01-20 22:19:11 EST
QE has finished cycle of virtio-win-prewhql-51 serial whql test .We did not hit this issue and all jobs passed.
Since build51 will ship to customers for windows8/windows 2012 platform  

Move status to VERIFIED and keep product flag to RHEL6.4.0
Comment 13 errata-xmlrpc 2013-02-21 05:39:04 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0441.html

Note You need to log in before you can comment on or make changes to this bug.