Bug 83370 - SiS 6326 fails at 1024x768x24
SiS 6326 fails at 1024x768x24
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-03 09:16 EST by Alan Cox
Modified: 2007-04-18 12:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-11 19:08:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2003-02-03 09:16:11 EST
The SiS drivers (both ours and Thomas) allow 1024x768x24 (and our config tools
prefer it). However the card apparently cannot manage that mode and runs out of
memory bandwidth or something (the results are pretty but not useful).

We should probably block  > 800x600 at 24bit on the 6326 to avoid the problem
occurring. 16bit is fine.
Comment 1 Mike A. Harris 2003-02-03 09:52:49 EST
Here are the modes the SiS 6326 specs show the hardware supports:

Supports super high resolution graphics modes
- 640x480		256/32K/64K/16M colors 85Hz NI
- 800x600		16/256/32K/64K/16M colors 85Hz NI
- 1024x768		16/256/32K/64K/16M colors 85Hz NI
- 1280x1024	16/256/32K/64K colors 75 Hz NI
- 1600x1200	16/256 colors 65Hz NI
- low resolution modes  (hidden)

By this chart, it should run in 1024x768x24bit at max of 85Hz refresh.
Could you attach your log file from it trying to start up at 1024x768x24?
Perhaps I can spot something in the code.  Also, if you would like, I
can give you a copy of the specs for this card if you don't have 'em.
Comment 2 Alan Cox 2003-02-03 10:05:04 EST
Works at 1024x768x60 @24bit
Fails at 72

Assuming your numbers are the final ones for the hardware and the vendor didnt
use crappier RAM (since I note you can strap the chip for multiple RAM speeds)
maybe the driver is
using 32bit with 8bit unused not packed 24 bit ?

Alan
Comment 3 Alan Cox 2003-11-11 19:08:10 EST
hardware issue, cant really be handled in software automatically.

Note You need to log in before you can comment on or make changes to this bug.