Bug 833738 - The "quota" command does not work to JbossEAP 6.0 application.
The "quota" command does not work to JbossEAP 6.0 application.
Status: CLOSED WORKSFORME
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Rob Millner
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-20 04:31 EDT by Yujie Zhang
Modified: 2015-05-14 18:55 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 11:44:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yujie Zhang 2012-06-20 04:31:41 EDT
Description of problem:

I created an jbosseap application and ssh to this application , tried the "quota" command, but there is no output of current disk usage.

Version-Release number of selected component (if applicable):

int.openshift.redhat.com

How reproducible:
always

Steps to Reproduce:
1.Go to openshift website and create a jbosseap applcation
2.ssh to the application 
3.try the "quota" command
  
Actual results:

The "quota" command does not work to Jbosseap applicaiton.

Expected results:

The "quota" command should work to Jbosseap application.

Additional info:
Comment 1 Bill DeCoste 2012-06-20 10:17:10 EDT
I was able to issue quota on an eap application without issue on devenv ami-1ea90b77. See below:

bash-4.2$ ssh 25f16b63b9c14fd6ab6c96dcdebaa3fb@eap1-bdecoste45a.dev.rhcloud.com

    *********************************************************************

    You are accessing a service that is for use only by authorized users.  
    If you do not have authorization, discontinue use at once. 
    Any use of the services is subject to the applicable terms of the 
    agreement which can be found at: 
    https://openshift.redhat.com/app/legal

    *********************************************************************

    Welcome to OpenShift shell

    This shell will assist you in managing OpenShift applications.

    !!! IMPORTANT !!! IMPORTANT !!! IMPORTANT !!!
    Shell access is quite powerful and it is possible for you to
    accidentally damage your application.  Proceed with care!
    If worse comes to worst, destroy your application with 'rhc app destroy'
    and recreate it
    !!! IMPORTANT !!! IMPORTANT !!! IMPORTANT !!!

    Type "help" for more info.

[eap1-bdecoste45a.dev.rhcloud.com ~]\> quota
Disk quotas for user 25f16b63b9c14fd6ab6c96dcdebaa3fb (uid 500): 
     Filesystem  blocks   quota   limit   grace   files   quota   limit   grace
     /dev/xvde2    9640       0 1048576             806       0   40000
Comment 2 Dan Mace 2012-06-20 10:26:56 EDT
I can't create an integration environment account right now due to bug 830136, but I can confirm that quota is working for a new jbosseap-6.0 app in ami-1ea90b77/devenv_1859:

=============

[dmace@thinkpad apps]$ rhc-create-app -a eaptest -t jbosseap-6.0 -l dmace53@example.com -p none
Creating application: eaptest in dmace53
Now your new domain name is being propagated worldwide (this might take a minute)...
    retry # 6 - Waiting for DNS: eaptest-dmace53.dev.rhcloud.com
Warning: Permanently added 'eaptest-dmace53.dev.rhcloud.com,23.20.153.141' (RSA) to the list of known hosts.
Confirming application 'eaptest' is available:  Success!

eaptest published:  http://eaptest-dmace53.dev.rhcloud.com/
git url:  ssh://cb3fa38ecac54cb3a025d35c39140c6b@eaptest-dmace53.dev.rhcloud.com/~/git/eaptest.git/
Successfully created application: eaptest

=============

[eaptest-dmace53.dev.rhcloud.com ~]\> quota
Disk quotas for user cb3fa38ecac54cb3a025d35c39140c6b (uid 500): 
     Filesystem  blocks   quota   limit   grace   files   quota   limit   grace
     /dev/xvde2    9664       0 1048576             812       0   40000        
[eaptest-dmace53.dev.rhcloud.com ~]\>
Comment 3 Jhon Honce 2012-06-20 11:38:28 EDT
I was able to run quota from int environment...

$ rhc app create -a jboss001 -pXXXX -t jbosseap-6.0 -d
Submitting form:
debug: true
rhlogin: jhonce@redhat.com
Contacting https://int.openshift.redhat.com
Creating application: jboss001 in honcenet
Contacting https://int.openshift.redhat.com
Response from server:
DEBUG:


Exit Code: 0
api_c: placeholder
broker_c: namespacerhloginsshapp_uuiddebugaltercartridgecart_typeactionapp_nameapi
API version:    1.1.3
DEBUG: 'jboss001' creation returned success.
Now your new domain name is being propagated worldwide (this might take a minute)...
Pulling new repo down
git clone --quiet ssh://65ca268ce5a8487781583f0a4fabe1de@jboss001-honcenet.int.rhcloud.com/~/git/jboss001.git/ jboss001
The authenticity of host 'jboss001-honcenet.int.rhcloud.com (107.21.74.30)' can't be established.
RSA key fingerprint is cf:ee:77:cb:0e:fc:02:d7:72:7e:ae:80:c0:90:88:a7.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added 'jboss001-honcenet.int.rhcloud.com,107.21.74.30' (RSA) to the list of known hosts.
remote: Counting objects: 39, done.
remote: Compressing objects: 100% (29/29), done.
remote: Total 39 (delta 1), reused 0 (delta 0)
Receiving objects: 100% (39/39), 19.30 KiB, done.
Resolving deltas: 100% (1/1), done.
Confirming application 'jboss001' is available
  Attempt # 1
Confirming application 'jboss001' is available:  Success!

jboss001 published:  http://jboss001-honcenet.int.rhcloud.com/
git url:  ssh://65ca268ce5a8487781583f0a4fabe1de@jboss001-honcenet.int.rhcloud.com/~/git/jboss001.git/
To make changes to 'jboss001', commit to jboss001/.
Successfully created application: jboss001

[jboss001-honcenet.int.rhcloud.com ~]\> quota
Disk quotas for user 65ca268ce5a8487781583f0a4fabe1de (uid 4376): 
     Filesystem  blocks   quota   limit   grace   files   quota   limit   grace
/dev/mapper/EBSStore01-user_home01
                   9664       0 1048576             811       0   40000

Note You need to log in before you can comment on or make changes to this bug.