Bug 833776 - unable to convert "\x93" warning message appears while gem installing or updating rhc
unable to convert "\x93" warning message appears while gem installing or upd...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
: Reopened, Triaged
: 834699 841297 844218 848103 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-20 06:45 EDT by Meng Bo
Modified: 2015-05-14 21:58 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 17:29:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2012-06-20 06:45:59 EDT
Description of problem:
Some charset related error message appears during gem install rhc on Fedora 17 platform.

Version-Release number of selected component (if applicable):
rhc-0.94.7

How reproducible:
always

Steps to Reproduce:
1.download latest rhc gem package 
2.install rhc via gem install
3.
  
Actual results:
some warning message "unable to convert "\xE7" from ASCII-8BIT to UTF-8 for" appears during the installation.

Expected results:
there should not have such warnings.

Additional info:

    Installing ri documentation for net-ssh-2.5.2...
    unable to convert "\xE7" from ASCII-8BIT to UTF-8 for lib/net/ssh/authentication/pageant.rb, skipping
    Installing ri documentation for archive-tar-minitar-0.5.2...
    Installing ri documentation for test-unit-2.5.0...
    Installing ri documentation for mime-types-1.18...
    Installing ri documentation for rest-client-1.6.7...
    Installing ri documentation for rhc-0.94.7...
    unable to convert "\x93" from ASCII-8BIT to UTF-8 for lib/rhc/vendor/zliby.rb, skipping
    Installing RDoc documentation for net-ssh-2.5.2...
    unable to convert "\xE7" from ASCII-8BIT to UTF-8 for lib/net/ssh/authentication/pageant.rb, skipping
    Installing RDoc documentation for archive-tar-minitar-0.5.2...
    Installing RDoc documentation for test-unit-2.5.0...
    Installing RDoc documentation for mime-types-1.18...
    Installing RDoc documentation for rest-client-1.6.7...
    Installing RDoc documentation for rhc-0.94.7...
    unable to convert "\x93" from ASCII-8BIT to UTF-8 for lib/rhc/vendor/zliby.rb, skipping
Comment 1 Clayton Coleman 2012-06-21 14:32:18 EDT
We have no control over this - please open a defect against the Fedora team if you can only recreate this on fedora.  If it fails on multiple platform, please contact me and we'll work to open an issue on upstream ruby.
Comment 2 Xiaoli Tian 2012-06-23 06:35:57 EDT
*** Bug 834699 has been marked as a duplicate of this bug. ***
Comment 3 Peter Ruan 2012-07-18 13:25:52 EDT
*** Bug 841297 has been marked as a duplicate of this bug. ***
Comment 4 Clayton Coleman 2012-07-29 23:44:07 EDT
We can't fix pageant, but we can fix zliby.
Comment 5 Clayton Coleman 2012-07-30 00:25:17 EDT
*** Bug 844218 has been marked as a duplicate of this bug. ***
Comment 6 Xiaoli Tian 2012-08-14 22:43:24 EDT
*** Bug 848103 has been marked as a duplicate of this bug. ***
Comment 7 Xiaoli Tian 2012-09-05 23:11:20 EDT
Move it to ON_QA, seems it's fixed in the latest version.
Comment 8 joycezhang 2012-09-05 23:18:44 EDT
This bug has been verified and fixed on Fedora17.

Please refer to the details as below:

Verified build:
rhc.0.98.8.gem


Verified steps:
1.# gem install rhc-0.98.8.gem

Verified results:
No warning messages are shown as below
# gem install rhc-0.98.8.gem
Successfully installed rhc-0.98.8
1 gem installed
Installing ri documentation for rhc-0.98.8...
Installing RDoc documentation for rhc-0.98.8...

It's fixed. Thanks.

Note You need to log in before you can comment on or make changes to this bug.