Bug 83378 - chop myheadoff caused segfault
Summary: chop myheadoff caused segfault
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: perl (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Chip Turner
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-03 16:35 UTC by bastiaan
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-21 12:47:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description bastiaan 2003-02-03 16:35:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020408

Description of problem:
Calling a 'chop' on an unquoted string causes Perl to segfault.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. perl -e 'chop myheadoff'
2.
3.
    

Actual Results:  [lmsbuild@crimelab src]$ perl -e 'chop myheadoff' 
Segmentation fault (core dumped)


Expected Results:  Perl should have printed an error message, like:
Can't modify constant item in chop at -e line 1, at EOF
Execution of -e aborted due to compilation errors.


Additional info:

Comment 1 Chip Turner 2003-04-21 12:47:20 UTC
fixed in perl in RH9


Note You need to log in before you can comment on or make changes to this bug.