Bug 833830 - Error building: 302 redirect to https on repository.apache.org
Error building: 302 redirect to https on repository.apache.org
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lee Newson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-20 08:52 EDT by Joshua Wulf
Modified: 2014-10-19 19:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-06 21:30:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2012-06-20 08:52:12 EDT
Got a bunch of errors like this after running mvn install (maven 3.0.3):

[ERROR] error: error reading  /home/jwulf/.m2/repository/commons-codec/commons-codec/1.6/commons-codec-1.6.jar; error in opening zip file


[jwulf@radhe csprocessor]$ cat /home/jwulf/.m2/repository/commons-codec/commons-codec/1.6/commons-codec-1.6.jar

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>302 Found</title>
</head><body>
<h1>Found</h1>
<p>The document has moved <a href="https://repository.apache.org/commons-codec/commons-codec/1.6/commons-codec-1.6.jar">here</a>.</p>
<hr>
<address>Apache/2.2.20 (Ubuntu) Server at repository.apache.org Port 80</address>
</body></html>

Found this: https://issues.apache.org/jira/browse/INFRA-1944

Changed pom.xml :
               <id>Apache</id>
        -        <url>http://repository.apache.org</url>
        +        <url>https://repository.apache.org</url>

Errors did not appear on next build.
Comment 1 Lee Newson 2012-06-20 18:41:59 EDT
In future if your filing bugs against a git repo then please specify the branch/tag. You can see what branch/tag your using by running "git status".

I've fixed this error in the maven and master branches. The issue was due to the ECS Maven repository being incorrectly setup.
Comment 2 Lee Newson 2012-06-20 18:45:12 EDT
Opps meant to say Apache and ECS Maven repositories. Which you pointed out for apache.
Comment 3 Lee Newson 2013-06-06 21:30:39 EDT
Closing and setting as current release as no QA was performed by the original reporter. If there is still an issue with this bug still than please re-open it.

Note You need to log in before you can comment on or make changes to this bug.