Bug 833836 - Maven build failure: Commonutilities-0.0.2-SNAPSHOT.jar not available in repos
Maven build failure: Commonutilities-0.0.2-SNAPSHOT.jar not available in repos
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lee Newson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-20 08:58 EDT by Joshua Wulf
Modified: 2014-10-19 19:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-06 21:31:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2012-06-20 08:58:01 EDT
maven 3.0.3

mvn -U install
...
Downloading: https://repository.jboss.org/nexus/com/redhat/Commonutilities/0.0.2-SNAPSHOT/Commonutilities-0.0.2-SNAPSHOT.jar
Downloading: https://repository.apache.org/com/redhat/Commonutilities/0.0.2-SNAPSHOT/Commonutilities-0.0.2-SNAPSHOT.jar
Downloading: http://repository-zanata.forge.cloudbees.com/release/com/redhat/Commonutilities/0.0.2-SNAPSHOT/Commonutilities-0.0.2-SNAPSHOT.jar
Downloading: http://ecsmaven.usersys.redhat.com/nexus/com/redhat/Commonutilities/0.0.2-SNAPSHOT/Commonutilities-0.0.2-SNAPSHOT.jar
...
[INFO] ECS Content Specification Tools ................... SUCCESS [0.352s]
[INFO] Content Specification Processor ................... FAILURE [5.666s]
...
[ERROR] Failed to execute goal on project csprocessor: Could not resolve dependencies for project com.redhat.contentspec:csprocessor:jar:0.0.2-SNAPSHOT: Could not find artifact com.redhat:Commonutilities:jar:0.0.2-SNAPSHOT in JBoss (https://repository.jboss.org/nexus/) -> [Help 1]
Comment 1 Lee Newson 2012-06-20 18:45:39 EDT
It does exist and I'd say it was due to the issue of the ECS Maven repository being incorrectly setup which I also discovered in Bug #833830.
Comment 2 Lee Newson 2013-06-06 21:31:12 EDT
Closing and setting as current release as no QA was performed by the original reporter. If there is still an issue with this bug still than please re-open it.

Note You need to log in before you can comment on or make changes to this bug.