Bug 833842 - [BUG] Manual provisioning fails on most families/arches
[BUG] Manual provisioning fails on most families/arches
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: scheduler (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 0.9.0
: ---
Assigned To: Bill Peck
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-20 09:06 EDT by Bill Peck
Modified: 2012-06-26 02:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-26 02:40:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Peck 2012-06-20 09:06:14 EDT
Description of problem:

Manual provisioning fails on most families/arches because the last call in %pre results in the following traceback:

Traceback (most recent call last):
  File "<stdin>", line 3, in <module>
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1199, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1489, in __request
    verbose=self.__verbose
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1253, in request
    return self._parse_response(h.getfile(), sock)
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1392, in _parse_response
    return u.close()
  File "/usr/lib64/python2.6/xmlrpclib.py", line 838, in close
    raise Fault(**self._stack[0])
xmlrpclib.Fault: <Fault 1: "<class 'bkr.common.bexceptions.BX'>:'No active recipe for dell-pesc430-02.rhts.eng.bos.redhat.com'">


Version-Release number of selected component (if applicable):
0.9.0-2

How reproducible:
Everytime
Comment 1 Bill Peck 2012-06-20 15:00:39 EDT
http://gerrit.beaker-project.org/#/c/1156/
Comment 2 Dan Callaghan 2012-06-21 18:29:00 EDT
This bug has been addressed in Beaker 0.9.0-3 which is currently running on stage:

https://beaker-stage.engineering.redhat.com/
Comment 3 Dan Callaghan 2012-06-26 02:40:40 EDT
Beaker 0.9.0 has been released.

Note You need to log in before you can comment on or make changes to this bug.