Bug 834086 - rhui proxy config, change default to http vs https and remove trailing slash from config
rhui proxy config, change default to http vs https and remove trailing slash ...
Status: CLOSED NOTABUG
Product: Pulp
Classification: Community
Component: z_other (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: John Matthews
Preethi Thomas
: Triaged
Depends On: 825011
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-20 15:10 EDT by James Slagle
Modified: 2013-09-27 18:25 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 825011
Environment:
Last Closed: 2013-09-27 18:25:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Slagle 2012-06-20 15:10:03 EDT
+++ This bug was initially created as a clone of Bug #825011 +++

Description of problem:

    if 'proxy_hostname' in answers:
        args += ['yum', 'proxy_url', 'https://%s/' % answers['proxy_hostname']]

--- Additional comment from whayutin@redhat.com on 2012-05-24 16:09:57 EDT ---

cloude commit 119d356eddac6185c199998a1df305c46d9cb5f6

--- Additional comment from whayutin@redhat.com on 2012-05-24 16:10:43 EDT ---

the trailing slash also caused repo syncs to fail... should work out of the box now for repo sync.

--- Additional comment from ssato@redhat.com on 2012-06-17 11:45:28 EDT ---

Created attachment 592446 [details]
[PATCH][grinder] normalize proxy_url and ensure it don't have extra trailing slashes

Hi, 


I came across this problem on customer site and looked into rh-rhui-tools, 
pulp and grinder. It looks it does no bad effects for rh-rhui-tools but 
grinder looks having problem w/ it.

I dont' know how the fix you made in the commit in comment #1 looks like 
and posted my patch for grinder normalizing proxy_url and ensure it
doesn't have extra trailing slahes just in case.


BTW, i tested normalize_proxy_url like the followings:

ssato@localhost% nosetests --with-doctest -v \
> grinder-0.0.136/src/grinder/BaseFetch.py
Doctest: grinder.BaseFetch.normalize_proxy_url ... ok

----------------------------------------------------------------------
Ran 1 test in 0.003s

OK
ssato@localhost%
Comment 1 James Slagle 2012-06-20 15:10:41 EDT
there is a submitted patch on the original bug.  please consider for inclusion in grinder.
Comment 2 Michael Hrivnak 2013-09-27 18:25:13 EDT
The description is very difficult to follow, but I'm gathering this was a problem in grinder. Pulp no longer uses grinder, so I'm closing this. Please re-open if you think it is still an issue in pulp.

Note You need to log in before you can comment on or make changes to this bug.