Bug 834092 - [abrt] pyvnc2swf-0.9.5-11.fc17: mp3.py:232:read_mp3file:AssertionError
[abrt] pyvnc2swf-0.9.5-11.fc17: mp3.py:232:read_mp3file:AssertionError
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: pyvnc2swf (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Timms
Fedora Extras Quality Assurance
abrt_hash:c6b68cde99f055758079b782757...
:
: 1078432 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-20 15:27 EDT by Mihkel Vain
Modified: 2014-04-26 09:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-21 05:59:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mihkel Vain 2012-06-20 15:27:25 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
cmdline:        python /usr/bin/vnc2swf-play 'T\xc3\xb6\xc3\xb6laud/googlereader.swf'
comment:        I tried to view a swf movie.
executable:     /usr/bin/vnc2swf-play
kernel:         3.4.2-4.fc17.x86_64
time:           K 20 juuni 2012 22:17:03 EEST
uid:            1000
username:       mihkel

backtrace:
:mp3.py:232:read_mp3file:AssertionError
:
:Traceback (most recent call last):
:  File "/usr/bin/vnc2swf-play", line 275, in <module>
:    if __name__ == "__main__": sys.exit(main(sys.argv))
:  File "/usr/bin/vnc2swf-play", line 273, in main
:    return play(args, info, debug=debug)
:  File "/usr/bin/vnc2swf-play", line 230, in play
:    movie.parse_vnc2swf(fname, True, debug=debug)
:  File "/usr/lib/python2.7/site-packages/pyvnc2swf/movie.py", line 169, in parse_vnc2swf
:    parser.open(fname)
:  File "/usr/lib/python2.7/site-packages/pyvnc2swf/swf.py", line 165, in open
:    getattr(self, name)(tag, length)
:  File "/usr/lib/python2.7/site-packages/pyvnc2swf/movie.py", line 413, in scan_tag19
:    self.movie.info.reg_mp3blocks(self.fp, length-4, nsamples, seeksamples)
:  File "/usr/lib/python2.7/site-packages/pyvnc2swf/movie.py", line 124, in reg_mp3blocks
:    MP3Reader(self.mp3).read_mp3file(fp, length, nsamples, seeksamples)
:  File "/usr/lib/python2.7/site-packages/pyvnc2swf/mp3.py", line 232, in read_mp3file
:    assert totalsamples == totalsamples0
:AssertionError
:
:Local variables in innermost frame:
:layer: 3L
:verbose: False
:bit_rate: 32
:length: 159
:copyright: False
:self: <mp3.MP3Reader instance at 0x271f200>
:s: 0
:emphasis: 0
:version: 2L
:totalsamples0: 576
:pad: 0
:channel: 3
:fp: <open file 'Töölaud/googlereader.swf', mode 'rb' at 0x2337300>
:framesize: 104
:totalsamples: 1152
:joint: 0
:nsamples: 576
:data: "\xff\xf3@\xc4\x8b\x161Z\x90\x04\xcb\x0c\x01\x80\x83\xd6D\x99dHf'}\xfd\xd9\xa8\xe6]\xdf\xfd\xfd\x86|w\x07\x86~\xcf\xcb\x1e\x1f\xbcr\xae\xca\xf9\x9b\xd3w\x86\x0fb\x1e\xf4~\x00\x00"
:b: 4
:h: 4294131908
:seeksamples: 372
:protected: False
:sample_rate: 22050
:x: ''
:original: True
Comment 1 David Timms 2012-06-21 05:59:42 EDT
Please note that vnc2swf-play is a limited swf player, designed to support only vnc screen movies made with vnc2swf.

I have earlier tried to avoid vnc2swf being set as the primary player of swf files, but not found a clean way to do it.

If anyone has any ideas regarding mime-types, and ensuring only the right types of files are opened by vnc2swf-play, please comment here.

Meanwhile, this bug is the same as: bug #620666
, and similar problem (package is not a generic swf player) to:
bug #769890 and bug #579640
Comment 2 Mihkel Vain 2012-06-23 06:09:03 EDT
Yeah. I was looking for some tool (other than web browser) to view and possibly edit (demux) swf files. Now I know that vnc2swf is not that tool :)
Comment 3 David Timms 2014-04-26 09:39:35 EDT
*** Bug 1078432 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.