Bug 834137 - Please remove kwrite dependency
Please remove kwrite dependency
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kde-baseapps (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-20 20:00 EDT by Sandro Mani
Modified: 2012-06-20 22:09 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 22:09:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sandro Mani 2012-06-20 20:00:26 EDT
Description of problem:
kde-baseapps depends on kwrite, because of an old upgrade path, the dependency however is now unnecessary (as confirmed to me once on #fedora-kde).
Moreover, it's terribly annoying having to reassign all text file associations from kwrite to kate if one prefers an editor with tabs.

Version-Release number of selected component (if applicable):
kde-baseapps-4.8.90-1.fc18.x86_64

Steps to Reproduce:
#yum erase kwrite
[...]
---> Package kwrite.x86_64 0:4.8.90-1.fc18 will be erased
--> Processing Dependency: kwrite for package: kde-baseapps-4.8.90-1.fc18.x86_64
--> Running transaction check
---> Package kde-baseapps.x86_64 0:4.8.90-1.fc18 will be erased
Comment 1 Rex Dieter 2012-06-20 21:46:46 EDT
agreed, it's been long enough.
Comment 2 Rex Dieter 2012-06-20 22:09:19 EDT
Unsure if we should remove the dep unconditionally or just for f18+ only.

will do the former.  maintainers, chime in with your opinion if you feel otherwise.

%changelog
* Wed Jun 20 2012 Rex Dieter <rdieter@fedoraproject.org> 4.8.90-2
- Please remove kwrite dependency (#834137)

Note You need to log in before you can comment on or make changes to this bug.