Bug 834166 - RHEV-H subdirectory lost in /var/log
RHEV-H subdirectory lost in /var/log
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
x86_64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
: Reopened, ZStream
: 846493 (view as bug list)
Depends On:
Blocks: 855390
  Show dependency treegraph
 
Reported: 2012-06-21 01:12 EDT by shaochen
Modified: 2016-04-26 10:42 EDT (History)
14 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-3.el6
Doc Type: Bug Fix
Doc Text:
In some circumstances hypervisor installation previously failed to create all required sub-directories of the '/var/log/' directory. Attempts to register such an installation to the Manager would fail because the '/var/log/vdsm-reg/' directory did not exist. The hypervisor has been updated to ensure that all required sub-directories of the '/var/log/' directory are always created during installation.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:36:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
ovirt.log (12.30 KB, text/plain)
2012-08-16 04:07 EDT, shaochen
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 67372 None None None 2012-09-05 13:40:47 EDT

  None (edit)
Description shaochen 2012-06-21 01:12:30 EDT
Description of problem:
RHEV-H subdirectory lost in /var/log

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120615.1.el6

How reproducible:
40%

Steps to Reproduce:
1. Make livecd to USB disk via command:
rhevh-iso-to-disk --format rhevh-6.3-20120615.1.el6.iso /dev/sdb
2. Boot from the livecd and install RHEV-H.
3. Reboot and login RHEV-H.
4. Focus on /var/log.
  
Actual results:
1. RHEV-H subdirectory lost in /var/log.
2. RHEV-H nic can up, but register to RHEV-M failed.

================================
# ls /var/log/
boot.log  core  dmesg  dmesg.old  lost+found  ovirt.log  rhsm  vdsm  wtmp

# ls /var/log/vdsm/
backup


Expected results:
1. RHEV-H all directory are complete.
# ls /var/log/
audit     btmp  cron   dmesg.old   lastlog  libvirtd.log  maillog   ntpstats   ovirt.log-tmp  sa      spooler   vdsm         vdsm-reg
boot.log  core  dmesg  dracut.log  libvirt  lost+found    messages  ovirt.log  rhsm           secure  tallylog  vdsm-config  wtmp

# ls /var/log/vdsm
backup  libvirt.log  metadata.log  vdsm.log

Additional info:
Comment 2 RHEL Product and Program Management 2012-07-10 03:18:51 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2012-07-10 21:51:14 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 4 Mike Burns 2012-07-11 09:51:07 EDT
I've looked at this in a couple of more recent builds and I don't see the problem manifesting anymore.  

The reason those didn't show up before was the mounting of /var/log didn't work somehow.  

Are you still able to reproduce this?
Comment 5 shaochen 2012-07-11 22:43:24 EDT
(In reply to comment #4)
> I've looked at this in a couple of more recent builds and I don't see the
> problem manifesting anymore.  
> 
> The reason those didn't show up before was the mounting of /var/log didn't
> work somehow.  
> 
> Are you still able to reproduce this?

Test several times with build rhev-hypervisor6-6.3-20120710.0.el6_3, I don't see the problem anymore. If can reproduce it, I will update info to here.
Thanks!
Comment 6 Mike Burns 2012-07-12 07:36:19 EDT
Per comment 5, cannot reproduce anymore, closing.  Please reopen if the issue manifests itself again
Comment 7 shaochen 2012-08-16 04:07:35 EDT
Created attachment 604810 [details]
ovirt.log

Reopen this bug due to reproduce it on rhevh-6.3-20120815.0.el6_3.

Test step:
1. Make livecd to USB disk via command:
# dd if=rhevh-6.3-20120815.0.el6_3.iso of=/dev/sdb
2. Boot from the livecd and install RHEV-H.
3. Reboot and login RHEV-H.
4. Focus on /var/log.

# ls /var/log/
boot.log  dmesg  lost+found  ovirt.log  rhsm  wtmp

Attach ovirt.log for your reference.
Comment 10 Mike Burns 2012-08-17 20:34:26 EDT
*** Bug 846493 has been marked as a duplicate of this bug. ***
Comment 18 errata-xmlrpc 2013-02-28 11:36:53 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.