Bug 834191 - copy and cut in the XmTextWidget don't work
copy and cut in the XmTextWidget don't work
Status: CLOSED DUPLICATE of bug 736205
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openmotif22 (Show other bugs)
6.2
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Thomas Woerner
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-21 03:25 EDT by Albert Flügel
Modified: 2012-07-06 12:14 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 478625
Environment:
Last Closed: 2012-07-06 12:14:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Program to demonstrate the bug. Compile with gcc textedit.c -o textedit /usr/lib64/libXm.so.3 -lXt -lX11 -g (65.37 KB, text/x-c)
2012-06-21 03:25 EDT, Albert Flügel
no flags Details

  None (edit)
Description Albert Flügel 2012-06-21 03:25:02 EDT
Created attachment 593372 [details]
Program to demonstrate the bug. Compile with gcc textedit.c -o textedit /usr/lib64/libXm.so.3 -lXt -lX11 -g

+++ This bug was initially created as a clone of Bug #478625 +++

Created attachment 328061 [details]
Patch to fix the but explained at motifzone.

Description of problem:
Copy and Cut in the XmTextWidget don't work.

Version-Release number of selected component (if applicable):
2.3.0-0.5.el5

How reproducible:
See URL. There you see, that motifzone has accepted and included the
fix, i've explained there.

Steps to Reproduce:
1. Download the text editor
2. compile like explained in URL
3. run the text editor
4. try to copy or cut and paste text in the text editor using the Edit menu
  
Actual results:
nothing is cut or copied

Expected results:
copy and cut do work

Additional info:
see URL.

--- Additional comment from mnowak@redhat.com on 2009-01-21 08:12:00 EST ---

Thanks for the investigation, changed the component to openmotif22; openmotif is unaffected then.

--- Additional comment from pm-rhel@redhat.com on 2009-11-06 13:56:26 EST ---

This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

--- Additional comment from pm-rhel@redhat.com on 2010-08-09 15:01:53 EDT ---

This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

--- Additional comment from pm-rhel@redhat.com on 2011-05-31 10:16:28 EDT ---

This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

--- Additional comment from pkovar@redhat.com on 2011-10-05 09:20:08 EDT ---


    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, cut and copy did not work in XmText widgets at all times. With this update, this problem has been solved.

--- Additional comment from lzachar@redhat.com on 2011-11-21 10:24:55 EST ---

Reproduced for old version.
Problem is fixed in the new version.

--- Additional comment from errata-xmlrpc@redhat.com on 2011-11-21 16:00:20 EST ---

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1467.html
Comment 2 Thomas Woerner 2012-07-06 12:14:14 EDT

*** This bug has been marked as a duplicate of bug 736205 ***

Note You need to log in before you can comment on or make changes to this bug.