Bug 834302 - edit cluster shows intel conroe instead when cluster is empty
edit cluster shows intel conroe instead when cluster is empty
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Shahar Havivi
Yaniv Kaul
virt
:
: 664422 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-21 09:24 EDT by Itamar Heim
Modified: 2015-09-22 09 EDT (History)
10 users (show)

See Also:
Fixed In Version: SI10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:01:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Itamar Heim 2012-06-21 09:24:19 EDT
an empty cpu name for the default cluster will allow the first host added to it to set the cluster cpu name.
need to make sure this only happens in clean install, and does not change the cpu name for an installed system (i.e., may be worth to fix the original script creating this, rather than a regular upgrade file)
Comment 2 Itamar Heim 2012-06-21 15:27:26 EDT
actually it is a bug...
the db does have it empty, just the UI shows the first entry instead of an empty entry

select cpu_name from vds_groups;
 cpu_name 
----------
 
(1 row)
Comment 3 Itamar Heim 2012-06-24 11:30:25 EDT
*** Bug 664422 has been marked as a duplicate of this bug. ***
Comment 4 Shahar Havivi 2012-06-25 08:23:16 EDT
post at: http://gerrit.ovirt.org/#/c/5674/
Comment 5 Yaniv Kaul 2012-07-05 07:57:55 EDT
SI9.1:
When creating a new cluster, you HAVE to specify a CPU level (whereas I'd expect the first host to set it). Is this the expected behavior?
It does show a default of empty, but you have to pick one to create the cluster object.
Comment 6 Shahar Havivi 2012-07-05 09:14:14 EDT
(In reply to comment #5)
> SI9.1:
> When creating a new cluster, you HAVE to specify a CPU level (whereas I'd
> expect the first host to set it). Is this the expected behavior?
> It does show a default of empty, but you have to pick one to create the
> cluster object.

you are creating a new cluster that have no host.
Comment 7 Yaniv Kaul 2012-07-05 09:48:31 EDT
(In reply to comment #6)
> (In reply to comment #5)
> > SI9.1:
> > When creating a new cluster, you HAVE to specify a CPU level (whereas I'd
> > expect the first host to set it). Is this the expected behavior?
> > It does show a default of empty, but you have to pick one to create the
> > cluster object.
> 
> you are creating a new cluster that have no host.

Indeed, and I was hoping the first host to join would determine the CPU level.
Adding a host is the next step in the wizard.
Comment 10 Haim 2012-08-07 02:24:15 EDT
verified on si13:

- cluster CPU for default cluster after clean install is determined by host cpu vendor.
- new cluster is set with empty cpu.

Note You need to log in before you can comment on or make changes to this bug.