Bug 834305 - Shell freezes using OSD Keyboard.
Shell freezes using OSD Keyboard.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell (Show other bugs)
7.0
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Florian Müllner
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-21 09:40 EDT by Vitezslav Humpa
Modified: 2014-06-13 07:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 07:33:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vitezslav Humpa 2012-06-21 09:40:50 EDT
Description of problem:

Enabling a Screen Display and trying to write into gnome-terminal led to GNOME Shell getting unresponsive. No keyboard or mouse input was possible. Only mouse cursor would change based on underlying context.

Version-Release number of selected component (if applicable):
gnome-shell-3.4.1-5.el7.x86_64
caribou-0.4.2-1.el7.x86_64

No other (notably caribou-gtk3-module) caribou package was installed.

How reproducible:
Could not reproduce after the first occurence

Actual results:
GNOME Shell freezing - see the relevant .xsession-errors file excerpt

Additional info:

Due to reduced reproducibility, this report will likely be useful only if this log is deemed relevant: the .xsession-errors relevant excerpt:

...
failed to create drawable
failed to create drawable
failed to create drawable
Gtk-Message: Failed to load module "caribou-gtk-module"
Gtk-Message: Failed to load module "caribou-gtk-module"
Gtk-Message: Failed to load module "caribou-gtk-module"
Gtk-Message: Failed to load module "caribou-gtk-module"
Gtk-Message: Failed to load module "caribou-gtk-module"
Traceback (most recent call last):
  File "<string>", line 1, in <module>
ImportError: No module named caribou.daemon.main
Window manager warning: Log level 32: Failed to load module "caribou-gtk-module"
gnome-session[9553]: WARNING: Not able to stop app from its condition: Not running
gnome-session[9553]: WARNING: Not able to stop app from its condition: Not running
Gtk-Message: Failed to load module "caribou-gtk-module"
Gtk-Message: Failed to load module "caribou-gtk-module"
Gtk-Message: Failed to load module "caribou-gtk-module"
Gtk-Message: Failed to load module "caribou-gtk-module"
Gtk-Message: Failed to load module "caribou-gtk-module"
Traceback (most recent call last):
  File "<string>", line 1, in <module>
ImportError: No module named caribou.daemon.main
Window manager warning: Log level 32: Failed to load module "caribou-gtk-module"
Comment 1 Matthias Clasen 2012-10-12 14:47:18 EDT
The on-screen keyboard works fine in 3.6.0.
Comment 2 Vladimir Benes 2013-01-18 10:22:38 EST
(In reply to comment #1)
> The on-screen keyboard works fine in 3.6.0.

it seems to be fixed in 3.6.3
-> VERIFIED
Comment 3 Ludek Smid 2014-06-13 07:33:23 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.