Bug 834369 - No sound from internal speakers but headphones work on Vaio VPC-Z12 with snd-hda-intel
No sound from internal speakers but headphones work on Vaio VPC-Z12 with snd-...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Patch, Triaged, Upstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-21 13:02 EDT by Eric
Modified: 2012-10-16 01:58 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-04 16:21:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Alsa-info output for P7120 latop on 3.3.7. (23.69 KB, text/plain)
2012-06-24 15:26 EDT, Philippe Troin
no flags Details
Alsa-info output for P7120 latop on 3.4.3 (27.43 KB, text/plain)
2012-06-24 15:30 EDT, Philippe Troin
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 960124 None None None 2012-06-21 13:02:53 EDT

  None (edit)
Description Eric 2012-06-21 13:02:53 EDT
Description of problem:
Sound does not work on internal speakers but does work on headphones on Vaio VPC-Z12 laptop.  Sound used to work fine in Fedora 16.

Version-Release number of selected component (if applicable):
Fedora 17, kernel 3.4.3-1.fc17.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Boot into Fedora 17
2.Try to play music
3.
  
Actual results: No sound from speakers, only on headphones when they are connected

Expected results: Sound from speakers


Additional info: Sound codec is Realtek ALC889. Booting KDE spin of Fedora 16, sound works on internal speakers, or on headphones correctly.  Booting KDE spin of Fedora 17, sound does not work on speakers, it works on headphones only. I tried adding "options snd-hda-intel model=sony-vaio-tt" to /etc/modprobe.d/vaioz.conf with no affect.
Comment 1 Philippe Troin 2012-06-24 15:00:21 EDT
Try installing a 3.3 kernel, 3.4 has had issues for me on similar hardware.
Comment 2 Philippe Troin 2012-06-24 15:26:52 EDT
Created attachment 594046 [details]
Alsa-info output for P7120 latop on 3.3.7.
Comment 3 Philippe Troin 2012-06-24 15:30:37 EDT
Created attachment 594047 [details]
Alsa-info output for P7120 latop on 3.4.3

I have attached the output of alsa-info for the last working kernel (3.3.7) and the latest Fedora kernel (3.4.3-1).
Comment 4 Adam Williamson 2012-08-04 03:11:39 EDT
I 'filed' this upstream (on the alsa-devel mailing list), and tiwai came up with a patch which should be making its way into the upstream kernel at present. http://koji.fedoraproject.org/koji/taskinfo?taskID=4337370 is a scratch F17 kernel build which includes the patch and ought to work. Kernel team, the commit is https://git.kernel.org/?p=linux/kernel/git/tiwai/sound.git;a=commit;h=e427c2375646789ecd0ccaef1a1e41458559ab2d , it looks like it's scheduled for 3.6, so we could backport it to 3.5 or just wait for 3.6 to go stable, either way.
Comment 5 Justin M. Forbes 2012-09-26 17:27:23 EDT
This patch is now in the F17 kernel, and should appear in 3.5.4-2 and later kernels. Please close if things are working for you when this kernel is available.
Comment 6 Eric 2012-10-04 16:21:06 EDT
I verified that sound works properly on the Vaio now with the new 3.5.4-2 kernel.  Thanks to all involved.  I can mark this as closed.
Comment 7 Shimi 2012-10-11 14:49:40 EDT
PsssT... Same here.

Today or Yesterday i update the my system, fedora 17 - kernel is updated to ver 3.5.6-1. Now i have this bug... :/

So... What's now?
Comment 8 Adam Williamson 2012-10-11 15:23:30 EDT
I guess the patch was dropped with the expectation the fix is in upstream 3.5.6 but it isn't? I'll check here and re-open if I can confirm.
Comment 9 Adam Williamson 2012-10-15 13:03:24 EDT
I got 3.6.1-1 on my last F17 update, and the sound is fine there for me. You?
Comment 10 Shimi 2012-10-16 01:58:48 EDT
Yes! sound is fine also for me. Thanks!

Note You need to log in before you can comment on or make changes to this bug.