Bug 834398 - Subscription Manager GUI : In first boot, at subscription registration page enter invalid credentials on clicking back button it displays an error message and gets stuck on Subscription Registration Progress page
Subscription Manager GUI : In first boot, at subscription registration page ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bryan Kearney
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-06-21 14:36 EDT by Sharath Dwaral
Modified: 2015-03-22 21:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:55:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
after clicking ok it gets stuck on this page (98.09 KB, image/png)
2012-06-21 14:36 EDT, Sharath Dwaral
no flags Details

  None (edit)
Description Sharath Dwaral 2012-06-21 14:36:47 EDT
Created attachment 593543 [details]
after clicking ok it gets stuck on this page

Description of problem:
In first boot, at subscription registration page enter invalid credentials on clicking back button it dispalys an error message and gets stuck on Subscription Registration Progress page.

Version-Release number of selected component (if applicable):

RHEL 5.9

# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-migration-1.0.4-1.git.1.b28337e.el5
subscription-manager-migration-data-1.11.1.1-1.git.2.c7fbafe.el5
python-rhsm-1.0.2-1.git.2.d5c3d05.el5
subscription-manager-firstboot-1.0.4-1.git.1.b28337e.el5
subscription-manager-1.0.4-1.git.1.b28337e.el5
subscription-manager-gui-1.0.4-1.git.1.b28337e.el5

How reproducible:
Always

Steps to Reproduce:
1. Unregister Subscription Manager  
   # subscription-manager unregister
2. Remove systemid file from /etc/sysconfig/rhn
3. RUN_FIRSTBOOT=YES in /etc/sysconfig/firstboot
4. Make sure only 69.pem is present in /etc/pki/product
5. # firstboot
6. Goto Subscription Registration page, enter invalid credentials
7. Click OK when error message pops up

Actual results:
After clicking "OK" it gets stuck on "subscription registration progress page"

Expected results:
Should take you to Subscription Registration page
Comment 1 RHEL Product and Program Management 2012-06-21 14:47:36 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Bryan Kearney 2012-08-13 09:34:56 EDT
Tested with 1.0.13 test version, and it is not there. PLease re-verity with 1.0.14 or later.
Comment 4 spandey 2012-08-27 03:52:26 EDT
Verified using following rpm with rhel5.9 

subscription-manager-1.0.14-1.git.24.812ba3e.el5
subscription-manager-firstboot-1.0.14-1.git.24.812ba3e.el5
subscription-manager-migration-data-1.11.2.3-1.git.4.8bd27be.el5
subscription-manager-migration-1.0.14-1.git.24.812ba3e.el5
subscription-manager-gui-1.0.14-1.git.24.812ba3e.el5


working fine resolving defect as verified
Comment 6 errata-xmlrpc 2013-01-07 22:55:51 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.