Bug 834417 - Yum reporting rawhide errors even though I don't have any rawhide repos active
Yum reporting rawhide errors even though I don't have any rawhide repos active
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-21 15:52 EDT by Joe Zeff
Modified: 2014-01-21 18:22 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-21 19:33:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Zeff 2012-06-21 15:52:19 EDT
Description of problem:

My laptop uses Fedora 16.  Every time I try to update it today using yumex, I get this error: ERROR: Error in yum Transaction : [u'ERROR with transaction check vs depsolve:', 'python(abi) = 2.6 is needed by (installed) rhpl-0.221-2.i686', u'Please report this error at https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum'] but checking, I have no rawhide repos listed.  Checking further, rhpl isn't listed among the updates needed.  Also, skip-broken is selected but has no effect.

Version-Release number of selected component (if applicable):

I'm using yumex 3.0.4 as a front end for yum 3.4.3

How reproducible:

100%

Steps to Reproduce:
1. Run yumex
2. Select all updates
3. Try to update
  
Actual results:

The update fails completely, with the above error message.

Expected results:

My system gets updated, with one or more updates skipped.

Additional info:

I also run Fedora 16 on my desktop and today's update went fine.  Of course, I don't have exactly the same things installed on both computers.
Comment 1 Michael Schwendt 2012-06-21 19:33:25 EDT
You are seriously confused about what the reason for this error is, and it has been explained on fedora users list. But since I just saw that you've posted about this at even another place (fedoraforum.org), which isn't nice as it occupies community support resources unnecessarily, a few more comments:

* Fedora 13 was the last release to include Python 2.6, which is what the "python(abi) = 2.6" dependency in the error message is related to

* Fedora 14 and newer include Python 2.7.x -- python(abi) = 2.7

* Package "rhpl" was last built in 2009 to be included in Fedora 12 for the last time.

* Some packages are retired between two releases of the Fedora distribution without anything removing them automatically. There is no garbage collection facility to do that, and such packages are not obsoleted/replaced by other packages either. It's up to the user to use tools like "yum list extras", "yum check" (or RPM queries) and search for packages, which no longer exist in the online repositories, then remove these manually.

* The bug tracker mentioned by Yum is just a default and doesn't imply that you run Rawhide. The Yum developers hope to learn about odd/unexpected depsolving errors that would be real bugs in Yum, but they very unlikely want to learn about all ordinary dependency issues caused by misconfiguration, broken packages, or temporarily broken repos.

Note You need to log in before you can comment on or make changes to this bug.