Bug 834450 - htons() gives warning if compiled with gcc -Wconversion [due to generic byteswap, non-x86/x86_64 platforms]
htons() gives warning if compiled with gcc -Wconversion [due to generic bytes...
Status: CLOSED DUPLICATE of bug 834447
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
17
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jeff Law
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-21 18:01 EDT by Alex Chernyakhovsky
Modified: 2012-06-21 18:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-21 18:09:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Sourceware 12194 None None None Never

  None (edit)
Description Alex Chernyakhovsky 2012-06-21 18:01:06 EDT
glibc fixed a bug in 2010 in which htons() would give a conversion warning when compiled with -Wconversion due to the implementation of the byte-swapping functions. Unfortunately, this fix was only for x86/x86_64 platforms. The fix has now been updated to include the generic byteswap functions.

Please apply this patch to the glibc in Fedora.

For reference, please see http://sourceware.org/bugzilla/show_bug.cgi?id=12194
Comment 1 Alex Chernyakhovsky 2012-06-21 18:09:52 EDT
Again, sorry, for the duplicate, RHBZ was acting up.

*** This bug has been marked as a duplicate of bug 834447 ***

Note You need to log in before you can comment on or make changes to this bug.