Bug 834471 - vdsm-gluster fails to open ports in iptables for gluster.
vdsm-gluster fails to open ports in iptables for gluster.
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
3.1 RC
Unspecified Linux
unspecified Severity high
: ---
: 3.2
Assigned To: Selvasundaram
gluster
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-21 19:45 EDT by Robert Middleswarth
Modified: 2013-02-26 19:45 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-15 01:47:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Middleswarth 2012-06-21 19:45:41 EDT
Description of problem:
Gluster ports are never opened and if you manually update the ports and then do something like reinstalling the node ports get closed again.

Version-Release number of selected component (if applicable):
oVirt Engine Version: 3.1.0-3.8.el6 also happened on beta1 as well.

How reproducible:
Every time.

Steps to Reproduce:
1.  Install a node with gluster enabled.
2.  gluster can't talk to any other network nodes.
3.
  
Actual results:
gluster can't talk to other gluster network.

Expected results:
gluster works.

Additional info:
Comment 1 Dan Kenigsberg 2012-06-22 08:50:27 EDT
iptable rules are kept on Engine's DB. vdsm only applies them during bootstrap.

in ovirt-node, the rules are part of ovirt-node.

(hmm, data duplication. we should find a way to avoid that)
Comment 2 Timothy Asir 2012-06-26 07:23:28 EDT
from where did you got the engine, vdsm rpms?
and where did you installed and received this error? (RHEL 6.3/?)
please provide the detail flow and logs.
  how did you installed the node with gluster enabled? (thru ui or anyother?)
  have you created any cluster or simply used the default cluster?

Notes:
you can find the engine logs from "/usr/share/jbossas/standalone/log/" directory
and the vdsm node logs in /var/log/vdsm/vdsm.log.

Supported platforms:
   RHSC downstream rpms: RHEL 6.3 server
   VDSM downstream rpms: RHS 2.0 only.
   RHSC upstream rpms:   Fedora 17.
Comment 3 Robert Middleswarth 2012-06-26 13:13:23 EDT
> from where did you got the engine, vdsm rpms?
I have used several builds all see the same things.  I used the 1st beta builds for F17 and installed later builds from Jenkins.  I have since moved on to using unoffical centos builds because Fedora 17 was just crashing every 10 to 12 hours.  Not an ovirt issue but Fedora 17 just wasn't usable.  

> and where did you installed and received this error? (RHEL 6.3/?)
Fedora 17, CentOS 6.2

> please provide the detail flow and logs.
I can attach logs from my latest build but it is a CentOS build 8 but I doubt they are officially supported however this should be very repeatable.

> how did you installed the node with gluster enabled? (thru ui or anyother?)
I did multiple installs.  In most installs I used the default cluster were I enabled VDSM support before installing the nodes.

>  have you created any cluster or simply used the default cluster?
On a few builds I created a new cluster with the same results.

Thanks
Robert
Comment 4 Timothy Asir 2012-07-02 07:19:19 EDT
I am suspecting that this could be a problem with the vdsm-bootstrap (older version). Can you please install the latest vdsm-bootstrap in the ovirt engine server and try!

if you still face an error then please attach the 
following files from the VDSM node:

/tmp/vds_bootstrap.*.log
/tmp/vds_installer.*.log
/tmp/deployUtil.py
/tmp/vds_bootstrap_*.py
/tmp/vds_installer_*.py
Comment 5 Selvasundaram 2012-10-03 03:05:26 EDT
The following engine patch will solve the IPTable rules (for gluster):

http://gerrit.ovirt.org/#/c/7243/
http://gerrit.ovirt.org/#/c/7244/
http://gerrit.ovirt.org/#/c/8000/
Comment 6 Itamar Heim 2013-01-16 11:08:40 EST
3.2 beta built, moving to ON_QA status to allow testing

Note You need to log in before you can comment on or make changes to this bug.