Bug 834536 - Fedora installation does not accept kickstart file written on DVD
Fedora installation does not accept kickstart file written on DVD
Status: CLOSED DUPLICATE of bug 828589
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-22 05:35 EDT by A.J. Werkman
Modified: 2012-06-28 22:48 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-28 22:48:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Dracut screen (908.25 KB, image/png)
2012-06-22 13:09 EDT, A.J. Werkman
no flags Details

  None (edit)
Description A.J. Werkman 2012-06-22 05:35:04 EDT
Description of problem:
Fedora installation does not accept kickstart file written on DVD

Version-Release number of selected component (if applicable):
17

How reproducible:
Everytime

Steps to Reproduce:
1. Prepare a Fedora 17 DVD with a kickstart file wirtten on it
2. Boot and direct the installation program to use the kickstart file on the DVD
3. Endup in a dracut debug shell
  
Actual results:
Installation ends up in a dracut debug shell saying it cannot do initqueue

Expected results:
Read the kickstart file and according to this onfo do the installation.

Additional info:
I use the following grub.conf:

default=0
timeout=20
splashimage=(cd)/boot/cfl.xpm.gz
title Local disk
	root (hd0)
	chainloader +1
title Fedora 17
	root (cd)
	kernel /images/pxeboot/vmlinuz nomodeset ks=cdrom:/ks.cfg root=live:CDLABEL=CFL17
	initrd /images/pxeboot/initrd.img
title Destructieve installation Fedora 17
	root (cd)
	kernel /images/pxeboot/vmlinuz nomodeset ks=cdrom:/cfl.cfg root=live:CDLABEL=CFL17
	initrd /images/pxeboot/initrd.img
title Test Fedora 17
	root (cd)
	kernel /images/pxeboot/vmlinuz nomodeset root=live:CDLABEL=CFL17
	initrd /images/pxeboot/initrd.img

The last option (without kickstart directive) can succesfully install Fedora, so I rule out DVD composing errors.
Comment 1 Chris Lumens 2012-06-22 10:53:11 EDT
Please attach /tmp/anaconda.log to this bug report.
Comment 2 A.J. Werkman 2012-06-22 13:09:34 EDT
Created attachment 593801 [details]
Dracut screen

At the moment I end up in a dracut debug shell there is no /tmp/anaconda.log (yet). I attach a photo of the screen.
Comment 3 Will Woods 2012-06-22 18:23:56 EDT
This seems like it might be a duplicate of bug 828589.

Does it work if you do 'ks=cdrom:/dev/cdrom:/ks.cfg' instead?
Comment 4 A.J. Werkman 2012-06-23 02:48:52 EDT
Yes the notation of comment 3 works.
Comment 5 Chris Lumens 2012-06-28 22:48:58 EDT

*** This bug has been marked as a duplicate of bug 828589 ***

Note You need to log in before you can comment on or make changes to this bug.