Bug 834659 - triggerd injects improper classad expressions into classad log file
triggerd injects improper classad expressions into classad log file
Status: CLOSED WONTFIX
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor-qmf (Show other bugs)
1.3
All All
medium Severity high
: 3.0
: ---
Assigned To: Robert Rati
MRG Quality Engineering
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-22 13:16 EDT by Erik Erlandson
Modified: 2012-07-30 15:30 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-30 15:30:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erik Erlandson 2012-06-22 13:16:44 EDT
Description of problem:
The triggerd can generate improper classad expressions for 'set attribute' (op code 103) operations in the job queue log file.

For example, this line:

103 1340101063 TriggerName Changed Test Trigger

is not a valid classad expression, and probably was intended to be a quoted string:

103 1340101063 TriggerName "Changed Test Trigger"


How reproducible:
100%


Additional info:
see also:
https://condor-wiki.cs.wisc.edu/index.cgi/tktview?tn=3069
https://bugzilla.redhat.com/show_bug.cgi?id=832331

Note You need to log in before you can comment on or make changes to this bug.