Bug 834675 - [abrt] openlierox-0.59-0.5.beta10.fc17: size: Process /usr/bin/openlierox was killed by signal 11 (SIGSEGV)
[abrt] openlierox-0.59-0.5.beta10.fc17: size: Process /usr/bin/openlierox was...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openlierox (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
abrt_hash:b07a0d6975123e61eb0680f9b5e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-22 14:26 EDT by Nick H.
Modified: 2012-08-10 03:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 19:00:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (11.04 KB, text/plain)
2012-06-22 14:26 EDT, Nick H.
no flags Details
File: maps (23.59 KB, text/plain)
2012-06-22 14:26 EDT, Nick H.
no flags Details
File: dso_list (4.82 KB, text/plain)
2012-06-22 14:26 EDT, Nick H.
no flags Details

  None (edit)
Description Nick H. 2012-06-22 14:26:33 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/bin/openlierox
crash_function: size
executable:     /usr/bin/openlierox
kernel:         3.4.3-1.fc17.x86_64
pid:            6085
pwd:            /home/nickhayes/Documents
time:           Fri 22 Jun 2012 12:15:28 PM MDT
uid:            1000

backtrace:      Text file, 11300 bytes
dso_list:       Text file, 4931 bytes
maps:           Text file, 24160 bytes

build_ids:
:d8167f71e1e2d0ac457d9237f4695816ec2456d0
:9d49f2f604fdc7a787f63c16cc08353956f2fd41
:b6d75088f555d197be1476cb1c580640826ae029
:aaa1236e690a9d2f230ade4b8d4387c22200ba9f
:73630857e782c47d12f6cc57c7daf1f1516a2626
:f1c5764c91642a33bec2d4ba5adbefc196cc8d60
:07d2432f2cea31e902ec19ecdc72dde8df873864
:091927b7a315243a2ff0383dfca1fd2c665405bf
:ff5a0c299ee54a2580475ad0d6cae351ec6cd4f6
:fad2d57f73db1d2b51917a93ac42fb4e1308b141
:f3249f55ce04635f2d4a6b8b6d0237a5c92bdbb3
:27b3fcec6b172b710e05eac89090e26760effab4
:0e1267a4d81de05f053eeed7f2f61fb46cda9e7c
:9d4e5b3f8f09e1fefc36a48c68dacc06276be529
:7854f755865cf71bd8c15ad701578345c4ffebee
:1a262290abc47e43b15d179c909c389831958b90
:5b3b844c8bf4cfac9e024beabd790a24d516db08
:f4f9ce91c43285df84177f9684a3e7f190a0aae1
:c2f5ae8bd64df0fc996cf96b95525a8f8fb28fd2
:4504beabd434c4e335d484b890a6adf1f8d995f6
:e230907ff55938fac70d429bf9784c52f054ebc6
:d8c1adae9befcad5f2a3b13d4d4f3bfb1a520313
:f64b7319b84d426ed547084bdb2577f4f596c18f
:cd6934c7ffdc10b4626f8a94336de83eb989545e
:127f8958b602715234a02b88adb08afd9e34c203
:350920b52e92655cdb258fa5f96fe7004ad07a52
:67792c148d2b8f13f6732c9367e926c26d7376c5
:516204cfc31148538d56b21e2f1b945ed50127d4
:63651cdc0224824a9c9324c77c3b5887378e871d
:c4ec0971b2dcee71aaf8374975474054245fea00
:3d60535f052babb998bae4807bc992c5d15df5c4
:73777e822e00ca152ffca281ab0ace0cb498ec48
:822e9b3523e8312240f41a25722d539bc77ed436
:8f1c8e7a9290087a1de608de917e41455f885af0
:5be9c729cee3f221a7e409b4b4e89c9ceb37395f
:86a3c9736fabd1aadaee4abae7ce24bfb3d3982b
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65
:396fda5abd0de2132396c4a3e94f7a7173bc26e7
:6e5d5649c704cd3a34cf145ccd2d08994f1e83ff
:4d09d82785dab5f95c01b69bc0785145a5954d30
:d789c08e9d240290a0a39e4654150029e152929f
:1555b1de25ee9aa6770b016dc6b0fc0372c073bd
:7654433afd142a4699559f45f290cd0bcfb0f2d6
:d32cbeacfd9f41e3cd29b697dd111f44a2d9c127
:10db86ab9481dc0e2bd0f0c4c987e86a8a1d9a8b
:00cc55fab9c160fa28f233c2d0c43ae9b03183a6
:5b4f3d35b4612be98f2bbb635b3eabf0ee7e437d
:ef8b8d492b07f4bb141fc3c32bc3bbf1c4c45275
:5dd234206476b0387cd251598aa72a2c95c763c5
:3aa8c8418a094c6b359df198f909bc3a65411b6b
:46bb3fa8cc22f53c1cb0461de27b3ab21912205e
:46eb8c83b266e03b4d2d37c5ac56accdee78c113
:5bf8427ddeff24a2bd36962f68e6af6ffe14970f
:1b7abd5c8129b91c0ca4f0f0812e61660236fd38
:247132297f287226a24c12e683292f5c94013066
:a749e2d7670ba481f7fbb58625f28507adca10bf
:2d920fc18d5d62c399484534249b104e12049777
:9dc7d977acebd2e8abf2d55bf2738ea2d89f7480

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/nickhayes/1

comment:
:Openlierox cannot be launched. :(
:When launching openlierox in the terminal, this is what I get EVERY time:
:---------------------------------------
:$ openlierox
:Segmentation fault (core dumped)
:$
:---------------------------------------

core_backtrace:
:516204cfc31148538d56b21e2f1b945ed50127d4 0xbd95d std::string::append(std::string libstdc++.so.6 -
:f3249f55ce04635f2d4a6b8b6d0237a5c92bdbb3 0x1d80df Logger::LockedStreamWrapper [exe] -
:f3249f55ce04635f2d4a6b8b6d0237a5c92bdbb3 0x4c7e3f SmartPointer<CWpnRest, [exe] -
:f3249f55ce04635f2d4a6b8b6d0237a5c92bdbb3 0x4bff72 Game::Game() [exe] -
:f3249f55ce04635f2d4a6b8b6d0237a5c92bdbb3 0x1cc85c - [exe] -
:f3249f55ce04635f2d4a6b8b6d0237a5c92bdbb3 0x7c274d __libc_csu_init [exe] -

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=1
:SSH_AGENT_PID=997
:HOSTNAME=Nick-HP-RedFox
:DM_CONTROL=/var/run/xdmctl
:XDG_MENU_PREFIX=kde4-
:SHELL=/bin/bash
:HISTSIZE=1000
:XDM_MANAGED=method=classic
:GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/home/nickhayes/.gtkrc-2.0:/home/nickhayes/.gtkrc-2.0-kde4:/home/nickhayes/.kde/share/config/gtkrc-2.0
:GS_LIB=
:KDE_FULL_SESSION=true
:QT_GRAPHICSSYSTEM_CHECKED=1
:USER=nickhayes
:SSH_AUTH_SOCK=/tmp/ssh-zfXVEXhVS962/agent.962
:MAIL=/var/spool/mail/nickhayes
:DESKTOP_SESSION=default
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/local/sbin:/usr/sbin:/home/nickhayes/.local/bin:/home/nickhayes/bin
:PWD=/home/nickhayes
:KDE_SESSION_UID=1000
:KDE_IS_PRELINKED=1
:LANG=en_US.UTF-8
:KDEDIRS=/usr
:SSH_ASKPASS=/usr/bin/ksshaskpass
:HISTCONTROL=ignoredups
:SHLVL=2
:XDG_SEAT=seat0
:HOME=/home/nickhayes
:KDE_SESSION_VERSION=4
:LOGNAME=nickhayes
:XDG_DATA_DIRS=/usr/share/kde-settings/kde-profile/default/share:/usr/local/share:/usr/share
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-NmUSeVW2ow,guid=a519509a864cef4788e1b66600000020
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/nickhayes
:DISPLAY=:0
:QT_PLUGIN_PATH=/home/nickhayes/.kde/lib64/kde4/plugins/:/usr/lib64/kde4/plugins/:/usr/lib/kde4/plugins
:XAUTHORITY=/tmp/kde-nickhayes/xauth-1000-_0
:_=/usr/libexec/kde4/start_kdeinit_wrapper
:KDE_MULTIHEAD=false
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1054,unix/unix:/tmp/.ICE-unix/1054
:GTK_RC_FILES=/etc/gtk/gtkrc:/home/nickhayes/.gtkrc:/home/nickhayes/.kde/share/config/gtkrc
:XCURSOR_THEME=default
:DESKTOP_STARTUP_ID=Nick-HP-RedFox;1340388928;237774;1114_TIME4903475

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 28905                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       28905                28905                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:pipe:[17875]
:pos:	0
:flags:	00
:1:/home/nickhayes/.xsession-errors
:pos:	48263
:flags:	0100001
:2:/home/nickhayes/.xsession-errors
:pos:	48263
:flags:	0100001

smolt_data:
:
:
:General
:=================================
:UUID: 2f30fe1b-e4b0-415a-b16f-cda423c81807
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 5585.63
:CPU Vendor: AuthenticAMD
:CPU Model: AMD Phenom(tm) II N620 Dual-Core Processor
:CPU Stepping: 3
:CPU Family: 16
:CPU Model Num: 6
:Number of CPUs: 2
:CPU Speed: 2800
:System Memory: 3698
:System Swap: 5759
:Vendor: Hewlett-Packard
:System: HP Pavilion dv6 Notebook PC 049C100003243010000020000
:Form factor: Notebook
:Kernel: 3.4.3-1.fc17.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4130:38406:4156:5183) pci, pcieport, PCI/PCI, RS780 PCI to PCI bridge (PCIE port 2)
:(4098:17297:4156:5183) pci, ahci, STORAGE, SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode]
:(4098:17302:4156:5183) pci, ehci_hcd, USB, SB7x0/SB8x0/SB9x0 USB EHCI Controller
:(4130:38401:4156:5183) pci, None, HOST/PCI, RS880 Host Bridge
:(4130:38402:4130:4661) pci, None, PCI/PCI, RS780/RS880 PCI to PCI bridge (int gfx)
:(4130:4612:0:0) pci, None, HOST/PCI, Family 10h Processor Link Control
:(4130:4609:0:0) pci, None, HOST/PCI, Family 10h Processor Address Map
:(4130:4608:0:0) pci, None, HOST/PCI, Family 10h Processor HyperTransport Configuration
:(4130:4611:0:0) pci, k10temp, HOST/PCI, Family 10h Processor Miscellaneous Control
:(4130:4610:0:0) pci, None, HOST/PCI, Family 10h Processor DRAM Controller
:(4098:17302:4156:5183) pci, ehci_hcd, USB, SB7x0/SB8x0/SB9x0 USB EHCI Controller
:(4098:17303:4156:5183) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
:(4332:33128:4156:5183) pci, r8169, ETHERNET, RTL8111/8168B PCI Express Gigabit Ethernet controller
:(4098:17285:4156:5183) pci, None, SERIAL, SBx00 SMBus Controller
:(4098:17309:4156:5183) pci, None, PCI/ISA, SB7x0/SB8x0/SB9x0 LPC host controller
:(4098:17283:4156:5183) pci, snd_hda_intel, MULTIMEDIA, SBx00 Azalia (Intel HDA)
:(4098:17305:4156:5183) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
:(4098:17284:0:0) pci, None, PCI/PCI, SBx00 PCI to PCI Bridge
:(4098:38674:4156:5183) pci, radeon, VIDEO, M880G [Mobility Radeon HD 4200]
:(4098:38671:4156:5183) pci, snd_hda_intel, MULTIMEDIA, RS880 Audio Device [Radeon HD 4200]
:(4098:17303:4156:5183) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
:(4098:17302:4156:5183) pci, ehci_hcd, USB, SB7x0/SB8x0/SB9x0 USB EHCI Controller
:(4098:17303:4156:5183) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
:(5772:43:4156:12352) pci, ath9k, NETWORK, AR9285 Wireless Network Adapter (PCI-Express)
:(4130:38405:4156:5183) pci, pcieport, PCI/PCI, RS780 PCI to PCI bridge (PCIE port 1)
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_nick--hp--redfox-lv_root / ext4 4096 4096 13091841 10497883 10366833 3276800 3065653 3065653
:/dev/sda1 /boot ext4 1024 1024 508644 397639 372039 128016 127611 127611
:/dev/mapper/vg_nick--hp--redfox-lv_home /home ext4 4096 4096 107256916 97943764 92574728 26845184 26829377 26829377
:

var_log_messages:
:Jun 22 12:06:28 Nick-HP-RedFox yum[5343]: Installed: openlierox-0.59-0.5.beta10.fc17.x86_64
:Jun 22 12:15:28 Nick-HP-RedFox kernel: [ 4893.760771] openlierox[6085]: segfault at ffffffffffffffe8 ip 0000003cf20bd95d sp 00007fff76d3a090 error 4 in libstdc++.so.6.0.17[3cf2000000+e5000]
:Jun 22 12:15:28 Nick-HP-RedFox abrt[6086]: Saved core dump of pid 6085 (/usr/bin/openlierox) to /var/spool/abrt/ccpp-2012-06-22-12:15:28-6085 (3690496 bytes)

xsession_errors:
:abrt-applet: repeated problem in openlierox-0.59-0.5.beta10.fc17, not showing the notification
:abrt-applet: repeated problem in openlierox-0.59-0.5.beta10.fc17, not showing the notification
:abrt-applet: repeated problem in openlierox-0.59-0.5.beta10.fc17, not showing the notification
Comment 1 Nick H. 2012-06-22 14:26:38 EDT
Created attachment 593809 [details]
File: backtrace
Comment 2 Nick H. 2012-06-22 14:26:42 EDT
Created attachment 593810 [details]
File: maps
Comment 3 Nick H. 2012-06-22 14:26:44 EDT
Created attachment 593811 [details]
File: dso_list
Comment 4 Hans de Goede 2012-08-03 11:22:20 EDT
Hmm, this seems to be caused by some silent ABI breakage in one of the deps, bad! Anyways a rebuilt fixes it, so an updated package is on its way.
Comment 5 Fedora Update System 2012-08-05 05:59:21 EDT
openlierox-0.59-0.6.beta10.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/openlierox-0.59-0.6.beta10.fc17
Comment 6 Fedora Update System 2012-08-05 17:32:04 EDT
Package openlierox-0.59-0.6.beta10.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openlierox-0.59-0.6.beta10.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11520/openlierox-0.59-0.6.beta10.fc17
then log in and leave karma (feedback).
Comment 7 akshay vyas 2012-08-09 14:58:47 EDT
whenevr i try to start the procss is killed by signal 11 after that i again try to restart it says

[akshay@localhost ~]$ openlierox
Segmentation fault (core dumped)


backtrace_rating: 4
Package: openlierox-0.59-0.6.beta10.fc17
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 8 Fedora Update System 2012-08-09 19:00:17 EDT
openlierox-0.59-0.6.beta10.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Hans de Goede 2012-08-10 03:05:55 EDT
(In reply to comment #7)
> whenevr i try to start the procss is killed by signal 11 after that i again
> try to restart it says
> 
> [akshay@localhost ~]$ openlierox
> Segmentation fault (core dumped)
> 
> 
> backtrace_rating: 4
> Package: openlierox-0.59-0.6.beta10.fc17
> Architecture: i686
> OS Release: Fedora release 17 (Beefy Miracle)

Hi,

Please let abrt add a new bug with a backtrace from the crash with the openlierox-0.59-0.6.beta10.fc17 version, without a backtrace I cannot debug this further.

Regards,

Hans

Note You need to log in before you can comment on or make changes to this bug.