Bug 834709 - kickstart needs a way to specify GPT partition tables
kickstart needs a way to specify GPT partition tables
Status: CLOSED DUPLICATE of bug 647810
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-22 16:42 EDT by joshua
Modified: 2012-09-07 19:20 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-07 19:20:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description joshua 2012-06-22 16:42:35 EDT
Description of problem:

Anaconda's kickstart needs a way to specify creating a GPT instead of the old style msdos partition tables.

zerombr and maybe clearpart need a way to specify this.

maybe just introduce a "zerogpt" directive that is mutually exclusive with zerombr?  Not sure of the best approach, but the partition table choice needs to be something that can be specified


Version-Release number of selected component (if applicable):

Fedora 17 x86_64
Comment 1 Brian Lane 2012-06-22 18:30:20 EDT
Adding an option to clearpart --initlabel is probably the right way to do this.
Comment 2 joshua 2012-07-06 18:39:53 EDT
Should this be F17 or rawhide?
Comment 3 Brian Lane 2012-07-09 15:21:47 EDT
F17 is fine. The fix will go into newui/rawhide.
Comment 4 Andrew McNabb 2012-09-07 18:24:05 EDT
Is this possibly a duplicate of bug #647810?
Comment 5 Brian Lane 2012-09-07 19:20:44 EDT

*** This bug has been marked as a duplicate of bug 647810 ***

Note You need to log in before you can comment on or make changes to this bug.