Bug 834722 - emacs segv's in getaddrinfo
emacs segv's in getaddrinfo
Status: CLOSED DUPLICATE of bug 839206
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Karel Klíč
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-22 18:10 EDT by Wolfgang Rupprecht
Modified: 2016-11-24 10:49 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-04 14:31:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wolfgang Rupprecht 2012-06-22 18:10:42 EDT
Description of problem:
emacs segv's inside getaddrinfo when I run M-x gnus.

Version-Release number of selected component (if applicable):
emacs.x86_64                       1:24.0.97-1.fc17             @updates-testing
emacs-bbdb.noarch                  1:2.35-7.fc17                @updates-testing
emacs-common.x86_64                1:24.0.97-1.fc17             @updates-testing
emacs-el.x86_64                    1:24.0.97-1.fc17             @updates-testing
emacs-filesystem.x86_64            1:24.0.97-1.fc17             @updates-testing
emacs-vm.x86_64                    8.1.2-1.fc17                 @/emacs-vm-8.1.2-1.fc17.x86_64

How reproducible:
always - for me.

Is there a emacs-debuginfo file that I can use to get a better idea of the args that are killing emacs?  

Steps to Reproduce:
1. run emacs -Q
2. m-x gnus
3. crash
  
Actual results:
emacs dies with a segv

Expected results:
emacs doesn't segv

Additional info:



[wolfgang@arbol ~]$ gdb emacs
GNU gdb (GDB) Fedora (7.4.50.20120120-49.fc17)
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/emacs...(no debugging symbols found)...done.
Missing separate debuginfos, use: debuginfo-install emacs-24.0.97-1.fc17.x86_64
(gdb) run -Q
Starting program: /usr/bin/emacs -Q
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
[New Thread 0x7ffff047d700 (LWP 2918)]
[New Thread 0x7fffefc7c700 (LWP 2919)]
Detaching after fork from child process 2920.
Detaching after fork from child process 2921.
Detaching after fork from child process 2922.

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff6ef4d9d in __libc_res_nsend () from /lib64/libresolv.so.2
(gdb) bt
#0  0x00007ffff6ef4d9d in __libc_res_nsend () from /lib64/libresolv.so.2
#1  0x00007ffff6ef2bd0 in __libc_res_nquery () from /lib64/libresolv.so.2
#2  0x00007ffff6ef35f0 in __libc_res_nsearch () from /lib64/libresolv.so.2
#3  0x00007fffed03dad8 in _nss_dns_gethostbyname4_r ()
   from /lib64/libnss_dns.so.2
#4  0x00007ffff73e00e2 in gaih_inet () from /lib64/libc.so.6
#5  0x00007ffff73e3c81 in getaddrinfo () from /lib64/libc.so.6
#6  0x00000000005ba55e in ?? ()
#7  0x000000000057832a in ?? ()
#8  0x00000000005b07cb in ?? ()
#9  0x0000000000577db1 in ?? ()
#10 0x000000000057810b in ?? ()
#11 0x00000000005b07cb in ?? ()
#12 0x0000000000577db1 in ?? ()
#13 0x000000000057810b in ?? ()
#14 0x00000000005b07cb in ?? ()
#15 0x0000000000577704 in ?? ()
#16 0x000000000057a961 in ?? ()
#17 0x00000000005b111e in ?? ()
#18 0x0000000000577db1 in ?? ()
#19 0x000000000057810b in ?? ()
#20 0x00000000005b07cb in ?? ()
#21 0x0000000000577db1 in ?? ()
#22 0x000000000057810b in ?? ()
#23 0x00000000005b07cb in ?? ()
#24 0x0000000000577704 in ?? ()
#25 0x000000000057a961 in ?? ()
#26 0x00000000005b111e in ?? ()
#27 0x0000000000577db1 in ?? ()
#28 0x000000000057810b in ?? ()
#29 0x00000000005b07cb in ?? ()
#30 0x0000000000577db1 in ?? ()
#31 0x000000000057810b in ?? ()
#32 0x00000000005b07cb in ?? ()
#33 0x0000000000577db1 in ?? ()
#34 0x000000000057810b in ?? ()
#35 0x00000000005b07cb in ?? ()
#36 0x0000000000577db1 in ?? ()
#37 0x000000000057810b in ?? ()
#38 0x0000000000574609 in ?? ()
#39 0x00000000005782a2 in ?? ()
#40 0x00000000005784e4 in ?? ()
#41 0x000000000050282e in ?? ()
#42 0x00000000005782c0 in ?? ()
#43 0x0000000000574609 in ?? ()
#44 0x00000000005782a2 in ?? ()
#45 0x00000000005784e4 in ?? ()
#46 0x00000000005103ac in ?? ()
#47 0x0000000000576481 in ?? ()
#48 0x00000000005037de in ?? ()
#49 0x000000000057637b in ?? ()
#50 0x00000000005048cf in ?? ()
#51 0x0000000000504bfd in ?? ()
#52 0x00000000004162f8 in ?? ()
#53 0x00007ffff7328735 in __libc_start_main () from /lib64/libc.so.6
#54 0x0000000000416ed9 in ?? ()
#55 0x00007fffffffdf38 in ?? ()
#56 0x000000000000001c in ?? ()
#57 0x0000000000000002 in ?? ()
#58 0x00007fffffffe2a0 in ?? ()
#59 0x00007fffffffe2af in ?? ()
#60 0x0000000000000000 in ?? ()
(gdb)
Comment 1 Wolfgang Rupprecht 2012-06-22 18:21:19 EDT
After downgrading glibc and cohorts emacs stopped segv-ing.   Probably a glibc bug.

Removed:
  glibc.x86_64 0:2.15-48.fc17           glibc-common.x86_64 0:2.15-48.fc17     
  glibc-devel.x86_64 0:2.15-48.fc17     glibc-headers.x86_64 0:2.15-48.fc17    

Installed:
  glibc.x86_64 0:2.15-37.fc17           glibc-common.x86_64 0:2.15-37.fc17     
  glibc-devel.x86_64 0:2.15-37.fc17     glibc-headers.x86_64 0:2.15-37.fc17
Comment 2 Siddhesh Poyarekar 2012-10-04 06:34:48 EDT
This will most likely depend on the configuration of gnus, i.e. your mail/news server, so if you could give me a way to reproduce it independently, then I can look at what the problem is.
Comment 3 Jeff Law 2012-10-04 14:31:15 EDT
-48 had some known problems in getaddrinfo and could fail in this manner depending on the exact contents of your resolv.conf.   Please update your glibc to 2.15.55 or newer.

Jeff

*** This bug has been marked as a duplicate of bug 839206 ***

Note You need to log in before you can comment on or make changes to this bug.