Bug 834736 - mount: you must specify the filesystem type
mount: you must specify the filesystem type
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: util-linux-ng (Show other bugs)
6.3
i686 Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Karel Zak
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-22 23:27 EDT by LunaSilverMoon
Modified: 2012-06-25 16:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-25 16:22:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description LunaSilverMoon 2012-06-22 23:27:23 EDT
Description of problem:
When trying to mount I must specify type of filesystem.  Just after the upgrade to 6.3 the mount command does not attempt to try figure out the filesystem so the -t is a must now.  This happens even with ext4.

Version-Release number of selected component (if applicable):


How reproducible:
mount /dev/mapper/LogVol06 /mnt/folder

Steps to Reproduce:
1.mount /dev/mapper/LogVol06 /mnt/folder
2.
3.
  
Actual results:
mount /dev/mapper/LogVol06 /mnt/folder
mount: you must specify the filesystem type
mount -t ext4 /dev/mapper/LogVol06 /mnt/folder

Expected results:
mount /dev/mapper/LogVol06 /mnt/folder

Additional info:
Comment 2 Karel Zak 2012-06-25 15:34:06 EDT
The command mount uses libblkid to recognize filesystem type. There is
no libblkid update in RHEL6.3.

Please , try

  BLKID_DEBUG=0xffff mount /dev/mapper/LogVol06 /mnt/folder &> blkid.log

and add blkid.log to bugzilla, thanks.
Comment 3 LunaSilverMoon 2012-06-25 16:20:13 EDT
Never mind you can close this off because it was a typo I did with another bug I reported.  It is working as it was.

Note You need to log in before you can comment on or make changes to this bug.