Bug 834752 - cannot print from networked computers
cannot print from networked computers
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: foomatic (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-23 05:04 EDT by antonio montagnani
Modified: 2013-02-24 01:52 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-24 01:52:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
troubleshooting file (22.26 KB, text/plain)
2012-06-23 05:04 EDT, antonio montagnani
no flags Details

  None (edit)
Description antonio montagnani 2012-06-23 05:04:21 EDT
Created attachment 593870 [details]
troubleshooting file

Description of problem:
in F17 I cannot print from networked computer

Version-Release number of selected component (if applicable):
not sure if connected to foomatic 4.0.8-8 or cups

How reproducible:
always

Steps to Reproduce:
1.set up a printer on a networked computer (that works fine)
2.try to print any document
3.
  
Actual results:
no print, sometimes I get the message that /filter/foomatic-rip failed, sometimes dnssd failed

Expected results:
it should print, as it was before switching to F17

Additional info:

su -c "lpinfo -l -v"
Password: 
Device: uri = http
        class = network
        info = IPP (Internet Printing Protocol) (http)
        make-and-model = Unknown
        device-id = 
        location = 
Device: uri = socket
        class = network
        info = AppSocket/HP JetDirect
        make-and-model = Unknown
        device-id = 
        location = 
Device: uri = beh
        class = network
        info = Backend Error Handler
        make-and-model = Unknown
        device-id = 
        location = 
Device: uri = smb
        class = network
        info = Windows Printer via SAMBA
        make-and-model = Unknown
        device-id = 
        location = 
Device: uri = https
        class = network
        info = IPP (Internet Printing Protocol) (https)
        make-and-model = Unknown
        device-id = 
        location = 
Device: uri = lpd
        class = network
        info = Host o stampante LPD/LPR
        make-and-model = Unknown
        device-id = 
        location = 
Device: uri = ipps
        class = network
        info = IPP (Internet Printing Protocol) (ipps)
        make-and-model = Unknown
        device-id = 
        location = 
Device: uri = ipp
        class = network
        info = IPP (Internet Printing Protocol) (ipp)
        make-and-model = Unknown
        device-id = 
        location = 
Device: uri = dnssd://Samsung%20ML-1610%20%40%20localhost._ipp._tcp.local/cups
        class = network
        info = Samsung ML-1610 @ localhost
        make-and-model = ML-1610
        device-id = 
        location = 
Device: uri = hp
        class = direct
        info = HP Printer (HPLIP)
        make-and-model = Unknown
        device-id = 
        location = 
Device: uri = hpfax
        class = direct
        info = HP Fax (HPLIP)
        make-and-model = Unknown
        device-id = 
        location =
Comment 1 Jiri Popelka 2012-06-25 05:05:24 EDT
There's error_log missing in the troubleshooter output for some reason.
Can you please fetch /var/log/cups/error_log manually after an unsuccessful print ?
See https://fedoraproject.org/wiki/Printing/Debugging#Getting_debug_information_by_other_means

Could you also temporarily switch off firewall to eliminate this possibility ?
Either with 'service iptables stop' or 'service firewalld stop' (in case you've been using F17 since beta or earlier).
Comment 2 antonio montagnani 2012-06-25 05:39:43 EDT
I solved by deleting printer and re-adding it!!! 
As during debugging I reinstalled also cups, I wondering if /var/log/cups/error_log is still available....and it can be useful
At the moment the computer is not available, please wait this evening (CET)
Comment 3 antonio montagnani 2013-02-24 01:52:31 EST
it seems solved

Note You need to log in before you can comment on or make changes to this bug.