Bug 834782 - empathy stops working after resume: unable to connect to telepathy account manager
empathy stops working after resume: unable to connect to telepathy account ma...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: telepathy-mission-control (Show other bugs)
17
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-23 11:04 EDT by Matteo Settenvini
Modified: 2012-09-27 08:58 EDT (History)
3 users (show)

See Also:
Fixed In Version: telepathy-mission-control-5.12.1-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-21 07:06:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 992619 None None None 2012-06-23 11:05:23 EDT

  None (edit)
Description Matteo Settenvini 2012-06-23 11:04:48 EDT
Description of problem:

After resuming from suspend, empathy stops working / connecting.
The error returned after starting it and waiting 10s or so, is:

---------------------

Error contacting the Account Manager

There was an error while trying to connect to the Telepathy Account Manager. The error was:

Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

---------------------

This seems related to launchpad bug 992619, only I don't use apparmor on Fedora :-p.

I can confirm that either restarting or killing both empathy and mission-control-5 fixes the issue (that is, until the next suspend + resume).

I had a look at audit.log and messages.log after starting setroubleshootd, but didn't find anything relevant.


Version-Release number of selected component (if applicable):

empathy-3.4.2.1-1.fc17.x86_64
telepathy-mission-control-5.12.0-1.fc17.x86_64
selinux-policy-3.10.0-132.fc17.noarch
selinux-policy-targeted-3.10.0-132.fc17.noarch
kernel-3.4.3-1.fc17.x86_64


How reproducible:

Always after suspend + resume on Thinkpad X121e.


Steps to Reproduce:

1. Connect to Internet and check empathy works
2. Suspend and resume
3. Open empathy

  
Actual results:

After ~10 seconds, errors pops up. Cannot open the account window, nor connect to any account.


Expected results:

Empathy works :-)
Comment 1 Peter Robinson 2012-07-16 07:00:47 EDT
can you check and see if this is fixed with telepathy-mission-control 5.12.1
Comment 2 Matteo Settenvini 2012-07-23 17:01:28 EDT
I tried with a couple of resume-and-suspends, and I can't reproduce this specific bug. However, no contact shows up in Empathy unless I remove geometry.ini in ~/.config/Empathy, kill it and start it again. 

I suppose it is a different problem though (and I can see it in Debian too, maybe it's related to some contact information retrieved from the server).

Thanks. Fixed for me.
Comment 3 Danil Kolobaev 2012-09-27 08:58:35 EDT
(In reply to comment #2)
> I tried with a couple of resume-and-suspends, and I can't reproduce this
> specific bug. However, no contact shows up in Empathy unless I remove
> geometry.ini in ~/.config/Empathy, kill it and start it again. 
> 
> I suppose it is a different problem though (and I can see it in Debian too,
> maybe it's related to some contact information retrieved from the server).
> 
> Thanks. Fixed for me.

Thanks, it worked for me too.

Note You need to log in before you can comment on or make changes to this bug.