Bug 834806 - Unable to assign priorities to certificate-based redhat repositories
Unable to assign priorities to certificate-based redhat repositories
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Bryan Kearney
Entitlement Bugs
:
Depends On:
Blocks: 771481
  Show dependency treegraph
 
Reported: 2012-06-23 14:51 EDT by o.h.weiergraeber
Modified: 2014-01-21 01:25 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:55:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description o.h.weiergraeber 2012-06-23 14:51:28 EDT
Description of problem:
As Redhat now recommends using certificate-based repositories instead of RHN Classic, I migrated my system using the rhn-migrate-classic-to-rhsm script. After that I tried to modify the redhat.repo file to include priority statements which are needed for yum-plugin-priorities.
Unfortunately, the priority=* lines seem to be removed automatically by the system!!!
Maybe there is an alternative location to define additional options for redhat repositories?

Version-Release number of selected component (if applicable):
yum-3.2.29-30.el6.noarch
(This is not really accurate, please correct if appropriate) 

How reproducible:
always

Steps to Reproduce:
1. Switch from RHN Classic to new-style subscription management
2. Try to define priorities in redhat.repo
  
Actual results:
Priority statements vanish from the file without notice.

Expected results:
Priority statements entered by the customer are permanent.
Alternatively, provide a different means to define repo priorities.

Additional info:
Comment 2 Bryan Kearney 2012-10-12 09:46:14 EDT
this should be fixed by https://bugzilla.redhat.com/show_bug.cgi?id=845349. Moving to ON_QA to verify..
Comment 6 John Sefler 2012-11-26 17:57:11 EST
Verified by https://bugzilla.redhat.com/show_bug.cgi?id=845349#c8
Comment 9 errata-xmlrpc 2013-02-21 03:55:16 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.