Bug 834819 - Kernel 3.3.7-1.fc16.i686
Kernel 3.3.7-1.fc16.i686
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
vbox first=3.3.7 tested=3.4.2
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-23 18:09 EDT by jd1008
Modified: 2012-07-09 15:37 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-09 15:37:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jd1008 2012-06-23 18:09:18 EDT
Description of problem: Kernel Ooops


Version-Release number of selected component (if applicable): 3.3.7-1.fc16.i686


How reproducible:reading an HFSPLUS mounted partition


Steps to Reproduce:
1.mount the hfsplus partition
2. start find <mount_point> -type f | xargs md5sum 
3.
  
Actual results: Kernel Oooops


Expected results: No oooops


Additional info:
Stack

[77338.535452] Oops: 0000 [#1] SMP 
[77338.535540] Modules linked in: nls_utf8 hfsplus ebtable_nat ebtables tun bridge stp llc rmd160 crypto_null target_core_mod camellia lzo cast6 cast5 deflate zlib_deflate cts gcm ccm serpent_sse2_i586 lrw serpent_generic xts gf128mul blowfish_generic blowfish_common twofish_generic twofish_i586 twofish_common xcbc sha512_generic des_generic geode_aes ah6 ah4 esp6 esp4 xfrm4_mode_beet xfrm4_tunnel tunnel4 xfrm4_mode_tunnel xfrm4_mode_transport xfrm6_mode_transport xfrm6_mode_ro xfrm6_mode_beet xfrm6_mode_tunnel ipcomp ipcomp6 xfrm_ipcomp xfrm6_tunnel tunnel6 af_key lockd vboxpci(O) vboxnetadp(O) vboxnetflt(O) vboxdrv(O) ipt_LOG xt_CHECKSUM ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 xt_state iptable_mangle ipt_MASQUERADE ip6table_filter ip6_tables iptable_nat nf_nat nf_conntrack_ipv4 nf_conntrack nf_defrag_ipv4 fuse snd_intel8x0m arc4 snd_intel8x0 snd_ac97_codec ac97_bus snd_seq ath9k mac80211 ath9k_common ath9k_hw rndis_host cdc_ether ath usbnet sunrpc snd_seq_device vfat fat snd_pcm cfg80211 snd_timer snd i2c_sis96x irda soundcore rfkill snd_page_alloc k8temp ppdev joydev parport_pc crc_ccitt serio_raw parport ecryptfs sha256_generic encrypted_keys trusted tpm tpm_bios uinput binfmt_misc sata_sil ata_generic firewire_ohci firewire_core sis900 pata_acpi yenta_socket mii crc_itu_t video pata_sis usb_storage radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]
[77338.536006] 
[77338.536006] Pid: 709, comm: md5sum Tainted: G    B    C O 3.3.7-1.fc16.i686 #1                  /        
[77338.536006] EIP: 0060:[<c042ee50>] EFLAGS: 00210246 CPU: 0
[77338.536006] EIP is at kmap+0x10/0x50
[77338.536006] EAX: 00000000 EBX: 00000000 ECX: 0000ffff EDX: d2f1a000
[77338.536006] ESI: 00000001 EDI: 00000fff EBP: d2f1bbfc ESP: d2f1bbf8
[77338.536006]  DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
[77338.536006] Process md5sum (pid: 709, ti=d2f1a000 task=ea167110 task.ti=d2f1a000)
[77338.536006] Stack:
[77338.536006]  c91025c0 d2f1bc18 f8b33f00 0000001b ca44952c 0000000c d2f1bc98 c91025c0
[77338.536006]  d2f1bc44 f8b35f44 0000000c 00000096 00000000 0000001e 0000000f ffffbc4c
[77338.536006]  c91025c0 00000001 d2f1bc98 d2f1bc84 f8b360de d2f1bc74 c0636b9b f8b35e69
[77338.536006] Call Trace:
[77338.536006]  [<f8b33f00>] hfsplus_bnode_read+0x40/0xb0 [hfsplus]
[77338.536006]  [<f8b35f44>] __hplusfs_brec_find+0x84/0x150 [hfsplus]
[77338.536006]  [<f8b360de>] hfsplus_brec_find+0xce/0x140 [hfsplus]
[77338.536006]  [<c0636b9b>] ? blk_queue_bio+0x29b/0x380
[77338.536006]  [<f8b35e69>] ? hfsplus_find_init+0x29/0x50 [hfsplus]
[77338.536006]  [<f8b30f3d>] hfsplus_ext_read_extent+0xbd/0x1c0 [hfsplus]
[77338.536006]  [<f8b315ed>] hfsplus_get_block+0xad/0x210 [hfsplus]
[77338.536006]  [<c055f79c>] block_read_full_page+0x13c/0x300
[77338.536006]  [<f8b31540>] ? hfsplus_file_extend+0x320/0x320 [hfsplus]
[77338.536006]  [<c050244d>] ? __inc_zone_page_state+0x1d/0x20
[77338.536006]  [<c04e8ee3>] ? add_to_page_cache_locked+0xc3/0x140
[77338.536006]  [<f8b2f674>] hfsplus_readpage+0x14/0x20 [hfsplus]
[77338.536006]  [<c04f2a37>] __do_page_cache_readahead+0x177/0x1e0
[77338.536006]  [<c04f2d06>] ra_submit+0x26/0x30
[77338.536006]  [<c04f2e31>] ondemand_readahead+0x121/0x210
[77338.536006]  [<c042edb9>] ? kmap_atomic_prot+0xe9/0x150
[77338.536006]  [<c04f2f9e>] page_cache_async_readahead+0x7e/0xa0
[77338.536006]  [<c04ea586>] generic_file_aio_read+0x426/0x6f0
[77338.536006]  [<c053460c>] do_sync_read+0xac/0xe0
[77338.536006]  [<c0534c0c>] ? rw_verify_area+0x6c/0x120
[77338.536006]  [<c05350cc>] vfs_read+0x8c/0x160
[77338.536006]  [<c0534560>] ? do_sync_write+0xe0/0xe0
[77338.536006]  [<c043e287>] ? irq_exit+0x67/0xa0
[77338.536006]  [<c05351dd>] sys_read+0x3d/0x70
[77338.536006]  [<c092ed64>] syscall_call+0x7/0xb
[77338.536006] Code: 74 26 00 8b 15 08 83 c6 c0 e8 9d fe ff ff 5d c3 8d 74 26 00 8d bc 27 00 00 00 00 55 89 e5 53 3e 8d 74 26 00 89 c3 e8 c0 ec 4f 00 <8b> 03 c1 e8 1e 69 c0 40 03 00 00 8d 90 40 27 ba c0 3b 90 cc 30 
[77338.536006] EIP: [<c042ee50>] kmap+0x10/0x50 SS:ESP 0068:d2f1bbf8
[77338.536006] CR2: 0000000000000000
Comment 1 Josh Boyer 2012-06-24 09:52:28 EDT
Your kernel is tainted with the B flag.  That means something else produced a BUG before this.  That would be the first thing someone would need to look at.  However, you also have the vbox modules loaded.

If you can recreate this without any of the vbox modules loaded, please let us know.
Comment 2 jd1008 2012-06-24 13:44:22 EDT
Sorry, I am not familiar with how a kernel get's tainted by the B flag.
How does that happen?
I will try to reproduce by unloading the vbox modules in single user
mode and will remount that hfs external drive and re-start tarring
the external drive out to another drive and verifying the md5 sums.
Comment 3 Justin M. Forbes 2012-06-26 12:44:10 EDT
Does this reproduce with the 3.4 kernels currently shipping for F16?
Comment 4 jd1008 2012-06-28 15:28:24 EDT
I have not tried to boot 3.4, but will do so soon and report back.
Comment 5 jd1008 2012-06-29 12:18:30 EDT
I just got a kernel oops in 3.4.2-1 but it is very different
from the kernel stack of this bug.
abrt reported that this kernel is also tainted.
How in tarnation does a kernel get tainted?

/var/log/messages shows:

Jun 29 09:06:21 localhost kernel: [356335.959866] BUG: Bad page state in process khugepaged  pfn:3cf14
Jun 29 09:06:21 localhost kernel: [356335.959880] page:f6b9b280 count:0 mapcount:0 mapping:  (null) index:0x1b9
Jun 29 09:06:21 localhost kernel: [356335.959887] page flags: 0x80000004(referenced)
Jun 29 09:06:21 localhost kernel: [356335.959895] Modules linked in: lp rndis_host cdc_ether usbnet nls_utf8 hfsplus usb_storage
 ebtable_nat ebtables tun bridge stp llc target_core_mod rmd160 crypto_null camellia_generic lzo cast6 cast5 deflate zlib_deflat
e cts gcm ccm serpent_sse2_i586 lrw serpent_generic xts gf128mul blowfish_generic blowfish_common twofish_generic twofish_i586 t
wofish_common xcbc sha512_generic des_generic geode_aes ah6 ah4 esp6 esp4 xfrm4_mode_beet xfrm4_tunnel tunnel4 xfrm4_mode_tunnel
 xfrm4_mode_transport xfrm6_mode_transport xfrm6_mode_ro xfrm6_mode_beet xfrm6_mode_tunnel ipcomp ipcomp6 xfrm_ipcomp xfrm6_tunn
el tunnel6 af_key lockd vboxpci(O) vboxnetadp(O) vboxnetflt(O) vboxdrv(O) xt_LOG ipt_MASQUERADE ip6t_REJECT nf_conntrack_ipv6 nf
_defrag_ipv6 iptable_nat nf_nat nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack xt_CHECKSUM ip6table_filter ip6_tables ip
table_mangle arc4 fuse ath9k snd_intel8x0m snd_intel8x0 mac80211 snd_ac97_codec ath9k_common ath9k_hw ac97_bus snd_seq vfat snd_
seq_de
Jun 29 09:06:21 localhost kernel: vice snd_pcm ath fat sunrpc snd_timer cfg80211 snd irda ppdev soundcore i2c_sis96x rfkill snd_
page_alloc k8temp parport_pc parport crc_ccitt serio_raw joydev ecryptfs sha256_generic encrypted_keys trusted tpm tpm_bios uinp
ut binfmt_misc sata_sil ata_generic firewire_ohci pata_acpi firewire_core sis900 yenta_socket mii crc_itu_t video pata_sis radeo
n ttm drm_kms_helper drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]
Jun 29 09:06:21 localhost kernel: [356335.960139] Pid: 23, comm: khugepaged Tainted: G         C O 3.4.2-1.fc16.i686 #1
Jun 29 09:06:21 localhost kernel: [356335.960146] Call Trace:
Jun 29 09:06:21 localhost kernel: [356335.960163]  [<c04ee4b7>] bad_page+0xa7/0xf0
Jun 29 09:06:21 localhost kernel: [356335.960173]  [<c04ef66c>] get_page_from_freelist+0x46c/0x520
Jun 29 09:06:21 localhost kernel: [356335.960182]  [<c04eed13>] ? free_pages_prepare+0x83/0x160
Jun 29 09:06:21 localhost kernel: [356335.960193]  [<c04ef87c>] __alloc_pages_nodemask+0x15c/0x780
Jun 29 09:06:21 localhost kernel: [356335.960206]  [<c052d527>] ? __mem_cgroup_uncharge_common+0xe7/0x2a0
Jun 29 09:06:21 localhost kernel: [356335.960215]  [<c0527eb6>] khugepaged+0x186/0x10d0
Jun 29 09:06:21 localhost kernel: [356335.960229]  [<c04554b0>] ? remove_wait_queue+0x40/0x40
Jun 29 09:06:21 localhost kernel: [356335.960237]  [<c0527d30>] ? collect_mm_slot+0x80/0x80
Jun 29 09:06:21 localhost kernel: [356335.960246]  [<c0454cd2>] kthread+0x72/0x80
Jun 29 09:06:21 localhost kernel: [356335.960256]  [<c0454c60>] ? kthread_freezable_should_stop+0x60/0x60
Jun 29 09:06:21 localhost kernel: [356335.960267]  [<c093ad3e>] kernel_thread_helper+0x6/0x10
Jun 29 09:06:21 localhost kernel: [356335.960272] Disabling lock debugging due to kernel taint
Jun 29 09:06:22 localhost abrt-dump-oops[953]: abrt-dump-oops: Found oopses: 1
Jun 29 09:06:22 localhost abrt-dump-oops[953]: abrt-dump-oops: Creating dump directories
Jun 29 09:06:22 localhost abrt-dump-oops: Reported 1 kernel oopses to Abrt
Jun 29 09:06:22 localhost abrtd: Directory 'oops-2012-06-29-09:06:22-953-0' creation detected
Jun 29 09:06:22 localhost abrtd: Can't open file '/var/spool/abrt/oops-2012-06-29-09:06:22-953-0/uid': No such file or directory
Jun 29 09:06:23 localhost abrtd: Sending an email...
Jun 29 09:06:23 localhost abrtd: Email was sent to: root@localhost
Jun 29 09:06:23 localhost abrtd: New problem directory /var/spool/abrt/oops-2012-06-29-09:06:22-953-0, processing
Jun 29 09:06:23 localhost abrtd: Can't open file '/var/spool/abrt/oops-2012-06-29-09:06:22-953-0/uid': No such file or directory
Comment 6 Dave Jones 2012-07-09 15:37:05 EDT
This still looks like it's caused by the virtual box modules.

Reopen if you can reproduce without them loaded.

Note You need to log in before you can comment on or make changes to this bug.