Bug 834840 - [abrt]: WARNING: at lib/list_debug.c:32 __list_add+0x8f/0xa0()
[abrt]: WARNING: at lib/list_debug.c:32 __list_add+0x8f/0xa0()
Status: CLOSED DUPLICATE of bug 829848
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:5a032f80d10ee8281cc8c004d54...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-24 03:19 EDT by Quentin Armitage
Modified: 2012-06-27 20:19 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-27 20:19:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Quentin Armitage 2012-06-24 03:19:12 EDT
libreport version: 2.0.10
cmdline:        BOOT_IMAGE=/vmlinuz-3.4.2-1.fc16.x86_64 root=/dev/mapper/vg_samson-lv_root ro rd.md=0 rd.dm=0 rd.lvm.lv=vg_samson/lv_swap quiet SYSFONT=latarcyrheb-sun16 rhgb rd.lvm.lv=vg_samson/lv_root KEYTABLE=uk rd.luks=0 LANG=en_US.UTF-8

backtrace:
:WARNING: at lib/list_debug.c:32 __list_add+0x8f/0xa0()
:Hardware name: SATELLITE PRO C660
:list_add corruption. prev->next should be next (ffff8802213be798), but was ffff880222754200. (prev=ffff880222754200).
:Modules linked in: fuse ebtable_nat ebtables ipt_MASQUERADE iptable_nat nf_nat xt_CHECKSUM iptable_mangle bridge stp llc lockd be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i libcxgbi cxgb3 mdio ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_netbios_ns nf_conntrack_broadcast nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack vhost_net macvtap macvlan tun kvm_intel kvm uvcvideo videobuf2_core videodev media videobuf2_vmalloc videobuf2_memops uinput sunrpc coretemp snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm arc4 toshiba_acpi sparse_keymap wmi ath9k mac80211 ath9k_common snd_timer ath9k_hw snd ath joydev i2c_i801 soundcore cfg80211 snd_page_alloc iTCO_wdt iTCO_vendor_support r8169 rfkill mii microcode crc32c_intel ghash_clmulni_intel i915 drm_kms_helper drm i2c
:_algo_bit i2c_core video ums_realtek usb_storage [last unloaded: scsi_wait_scan]
:Pid: 0, comm: swapper/0 Not tainted 3.4.2-1.fc16.x86_64 #1
:Call Trace:
: <IRQ>  [<ffffffff810579df>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff81057ad6>] warn_slowpath_fmt+0x46/0x50
: [<ffffffff812da1fb>] ? swiotlb_tbl_sync_single+0x3b/0x80
: [<ffffffff812d2c6f>] __list_add+0x8f/0xa0
: [<ffffffffa02c2ab1>] ath_rx_tasklet+0x281/0x1bb0 [ath9k]
: [<ffffffff81090087>] ? update_shares+0xc7/0x110
: [<ffffffffa02bcd15>] ? ath9k_ioread32+0x35/0x90 [ath9k]
: [<ffffffffa02c0f64>] ath9k_tasklet+0xf4/0x170 [ath9k]
: [<ffffffff8105f474>] tasklet_action+0x64/0xe0
: [<ffffffff8105ee78>] __do_softirq+0xb8/0x230
: [<ffffffff810376f4>] ? ack_apic_level+0x74/0x140
: [<ffffffff8160171c>] call_softirq+0x1c/0x30
: [<ffffffff81016215>] do_softirq+0x65/0xa0
: [<ffffffff8105f28e>] irq_exit+0x9e/0xc0
: [<ffffffff81601f73>] do_IRQ+0x63/0xe0
: [<ffffffff815f85ea>] common_interrupt+0x6a/0x6a
: <EOI>  [<ffffffff8131a57a>] ? intel_idle+0xea/0x150
: [<ffffffff8131a55c>] ? intel_idle+0xcc/0x150
: [<ffffffff814a7129>] cpuidle_enter+0x19/0x20
: [<ffffffff814a773c>] cpuidle_idle_call+0xac/0x2a0
: [<ffffffff8101d61f>] cpu_idle+0xcf/0x120
: [<ffffffff815d510e>] rest_init+0x72/0x74
: [<ffffffff81cf6c11>] start_kernel+0x3b7/0x3c4
: [<ffffffff81cf665a>] ? repair_env_string+0x5a/0x5a
: [<ffffffff81cf6346>] x86_64_start_reservations+0x131/0x135
: [<ffffffff81cf6140>] ? early_idt_handlers+0x140/0x140
: [<ffffffff81cf644c>] x86_64_start_kernel+0x102/0x111
Comment 1 Quentin Armitage 2012-06-25 03:57:15 EDT
I had previously been running kernel 3.3.7-1.fc16 and had not experienced this problem. After booting 3.4.2-1.fc16 this problem started to occur, and after rebooting due to this crash 4 times in the space of 4 hours I reverted to kernel 3.3.8-1.fc16 which has now been running without the problem for 21 hours.
Comment 2 Quentin Armitage 2012-06-27 20:19:52 EDT

*** This bug has been marked as a duplicate of bug 829848 ***

Note You need to log in before you can comment on or make changes to this bug.