Bug 834841 - Ovirt CLI - Can't remove network
Ovirt CLI - Can't remove network
Status: CLOSED DUPLICATE of bug 834198
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-cli (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Pasternak
Oded Ramraz
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-24 03:39 EDT by Elena
Modified: 2016-02-10 14:48 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-24 04:00:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elena 2012-06-24 03:39:07 EDT
delete network testrest1
unknown error: None

2012-06-24 10:34:27,939 WARN  [org.ovirt.engine.core.bll.storage.RemoveNetworkCommand] (ajp--0.0.0.0-8009-8) [3cc612a8] CanDoAction of action RemoveNetwork failed. Reasons:VAR__ACTION__REMOVE,VAR__TYPE__NETWORK,NETWORK_CLUSTER_NETWORK_IN_USE
2012-06-24 10:34:27,940 ERROR [org.ovirt.engine.api.restapi.resource.AbstractBackendResource] (ajp--0.0.0.0-8009-8) Operation Failed: [Cannot remove Network. Network is being used by at least one Cluster.]

Same action with same parameters works perfect with REST API

I suggest there is the same problem with search networks bug and api just try to remove the wrong network
Comment 1 Michael Pasternak 2012-06-24 04:00:48 EDT
Elena, this is very same issue as in :
#834198 - OVIRT-CLI: update network by name doesn't work

i.e get-network-by-name doesn't work, in meanwhile you can delete by-id

*** This bug has been marked as a duplicate of bug 834198 ***

Note You need to log in before you can comment on or make changes to this bug.