Bug 834854 - Ovirt CLI - Can't create vm disk when specifying storage domain
Ovirt CLI - Can't create vm disk when specifying storage domain
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.1.0
Assigned To: Ori Liel
Oded Ramraz
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-24 05:54 EDT by Elena
Modified: 2016-02-10 11:35 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-24 08:41:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elena 2012-06-24 05:54:58 EDT
create disk --vm-identifier '339857a2-642c-4d0b-b4d5-02bda1c7ac66'   --storage_domains-storage_domain-id 'd2c04ba8-1e64-4f87-b3e7-acf27888335f' --format 'cow' --sparse true --interface 'virtio' --size 214748364

error: syntax error "%s", see help on collection based arguments for more details.
Comment 1 Elena 2012-06-24 05:56:14 EDT
Storage domain is required for vm first disk creation
Comment 2 Michael Pasternak 2012-06-24 06:11:18 EDT
error: syntax error at "--storage_domains-storage_domain-id", see help on collection based arguments for more details.

this bug caused by incorrect parameter representation in RSDL,
storage_domains [1] implemented as collection while RSDL reporting 
it as Type

[1]

    public List<StorageDomain> getStorageDomains() {
        if (storageDomains == null) {
            storageDomains = new ArrayList<StorageDomain>();
        }
        return this.storageDomains;
    }
Comment 3 Michael Pasternak 2012-06-24 08:41:39 EDT
my bad, - (was on old branch), current RSDL impl is correct (see cli help [1]), usage is not, Elena please always review /help/ to determinate correct option format.

[1]

     Overload 1:
     
     * --size: int
     * --type: string
     * --interface: string
     * --format: string
     * [--sparse: boolean]
     * [--bootable: boolean]
     * [--shareable: boolean]
     * [--allow_snapshot: boolean]
     * [--propagate_errors: boolean]
     * [--wipe_after_delete: boolean]
     * [--storage_domains: collection]
       {
         [storage_domain.id|name: string]
       }

Note You need to log in before you can comment on or make changes to this bug.