Bug 834890 - webadmin: CanDoAction of action UpdateStoragePool failure is not propagated to the UI
webadmin: CanDoAction of action UpdateStoragePool failure is not propagated t...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity high
: ---
: 3.1.0
Assigned To: Asaf Shakarchi
Daniel Paikov
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-24 11:15 EDT by Yaniv Kaul
Modified: 2016-02-10 11:59 EST (History)
12 users (show)

See Also:
Fixed In Version: si13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:06:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaniv Kaul 2012-06-24 11:15:00 EDT
Description of problem:
I've tried to change the default Data Center's storage type (which was NFS, to local storage). I'm getting no error from the UI when pressing OK, but the dialog remains (with the change) on screen. 

The backend has the failure:
2012-06-24 18:11:56,370 WARN  [org.ovirt.engine.core.bll.storage.UpdateStoragePoolCommand] (ajp--0.0.0.0-8009-5) [2782756d] CanDoAction of action UpdateStoragePool failed. Reasons:VAR__TYPE__STORAGE__POOL,ACTION_TYPE_FAILED_STORAGE_POOL_WITH_DEFAULT_VDS_GROUP_CANNOT_BE_LOCALFS,VAR__ACTION__UPDATE

Version-Release number of selected component (if applicable):
si7 
rhevm-webadmin-portal-3.1.0-2.el6ev.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Barak 2012-07-04 08:26:16 EDT
1 - Basically this action  (change storage type of DC) should not be permitted.
2 - There are  2 cases it may logically make sense
    * when created it by mistake (before assigning it storage domains and 
      hosts), and in this case the correction should be deletion and recreation.
    * after adding hosts to a cluster and before assigning SDs to it possible    
      moving the hosts one by one to another cluster within another DC (this 
      time with the right storage type) .... time consuming

Bottom line I think this should be solved by disabling editing the DC storage type.
Comment 3 Asaf Shakarchi 2012-07-04 09:46:47 EDT
By the way I cannot reproduce this issue, I just tested and it seems like the error is actually propagated to the UI properly,

Maybe it was fixed at some point.

please answer Barak's comment so I can know how to proceed.
Comment 4 Ayal Baron 2012-07-08 17:47:46 EDT
I disagree with Barak here as user might have defined networks and would like not to repeat the work (let's say everything is defined but storage is being migrated).

However, going forward we will remove the storage type limitation altogether so it doesn't look worth it enabling this.
Unless this is a regression (i.e. this was possible in a previous version) fix should be to block the operation.
Yaniv?
Comment 5 Yaniv Kaul 2012-07-19 07:59:25 EDT
(In reply to comment #1)
> 1 - Basically this action  (change storage type of DC) should not be
> permitted.
> 2 - There are  2 cases it may logically make sense
>     * when created it by mistake (before assigning it storage domains and 
>       hosts), and in this case the correction should be deletion and
> recreation.

That's ugly. Delete and re-creating is an obvious workaround for this BZ. 
This BZ is about not needing to perform this workaround.

However, if you do not wish to fix, then indeed disabling the edit (or disallowing to change the type) is a second best option.
Comment 6 Ayal Baron 2012-07-25 07:57:21 EDT
Acking for greying out the DC type box when there are storage domains in DC.
Comment 7 Asaf Shakarchi 2012-07-25 11:26:26 EDT
Patch submitted:

http://gerrit.ovirt.org/#/c/6624/
Comment 8 Asaf Shakarchi 2012-07-30 07:25:02 EDT
Committed [9943eeb946c18572]
Comment 10 Haim 2012-08-06 11:12:40 EDT
the following error is propagated to UI:

error: Default Cluster cannot be moved to the Data Center that has local Storage.

2012-08-06 21:27:38,309 WARN  [org.ovirt.engine.core.bll.storage.UpdateStoragePoolCommand] (ajp-/127.0.0.1:8009-11) [161e2a7] CanDoAction of action UpdateStoragePool failed. Reasons:VAR__TYPE__STORAGE__POOL,ACTION_TYPE_FAILED_STORAGE_POOL_WITH_DEFAULT_VDS_GROUP_CANNOT_BE_LOCALFS,VAR__ACTION__UPDATE

Note You need to log in before you can comment on or make changes to this bug.